Bug 504488 - xorg sis driver doesn't work correctly on D201GLY integrated video card
xorg sis driver doesn't work correctly on D201GLY integrated video card
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-sis (Show other bugs)
19
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch, Reopened, Triaged
: 651615 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-07 09:12 EDT by Igor Mammedov
Modified: 2015-02-18 06:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 651615 (view as bug list)
Environment:
Last Closed: 2015-02-18 06:59:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
working sis driver source (1.43 MB, application/x-gzip)
2009-06-07 09:15 EDT, Igor Mammedov
no flags Details
Patched driver that works with sis662 on Xorg 1.9 (1.58 MB, application/x-gzip)
2011-03-13 15:26 EDT, Igor Mammedov
no flags Details
RHEL6.2 SiS662 x86_64 binary video driver from aur.archlinux.org (276.82 KB, application/x-gzip)
2011-12-23 16:45 EST, valery.kirichenko
no flags Details
Total patch to compile SiS driver web24.server5.publicompserver.de/linux/sis/xf86-video-sis671-0.9.1.tar.gz on RHEL6.2 xorg 1.10.4 (33.80 KB, patch)
2011-12-24 12:46 EST, valery.kirichenko
no flags Details | Diff

  None (edit)
Description Igor Mammedov 2009-06-07 09:12:41 EDT
Description of problem:
a lot of noise on the screen mostly grouped to several vertical bands.  

Version-Release number of selected component (if applicable):
xorg-x11-drv-sis-0.10.1-2.fc11.i586

How reproducible:
set a high resolution (1024x768 or higher)


Expected results:
no noise

Additional info:
I've finely found working driver at http://launchpadlibrarian.net/24820246/xorg-driver-sis671_0.9.tar.gz
Commented out lines 3330-3333 in src/sis_driver.c to allow usage of sis662
This driver somewhat newer than a fedora's driver.
It would be nice if fedora's sis driver worked out of box. 
Modified driver is attached.
Comment 1 Igor Mammedov 2009-06-07 09:15:23 EDT
Created attachment 346782 [details]
working sis driver source
Comment 3 Matěj Cepl 2009-11-05 13:30:52 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 4 Christian 2009-11-18 17:22:58 EST
The "xorg-driver-sis671-0.9.tar.gz" found and modified by Igor Mammedov 
compiled & worked fine on Fedora 11 but does not compile anymore on F12

   sis.h:74:27: error: xf86Resources.h: No such file or directory

It seems that the package xorg-x11-server-Xorg Version: 1.6.4 used in F11 
have some differences with the version: 1.7.1 used in F12 regarding the file 
xf86Resources.h

On F11 the file xf86Resources.h was supplied by these two packages :

   xorg-x11-server-devel-1.6.4-0.1.fc11.i586 
   xorg-x11-server-source-1.6.4-0.1.fc11.i586

On F12 the file xf86Resources.h is not part of these 3 packages :

   xorg-x11-server-devel-1.7.1-7.fc12.x86_64
   xorg-x11-server-devel-1.7.1-7.fc12.i686
   xorg-x11-server-source-1.7.1-7.fc12.noarch

Other info : The standart RPM "xorg-x11-drv-sis-0.10.2-1.fc12.x86_64" 
does not work for Fedora 12 (display vertical noisy lines).

I am using the stock F12 kernel 2.6.31.5-127.fc12.x86_64 with D201GLY2 Mobo
with the IGP [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter 
01:00.0 0300: 1039:6330 (rev 04)

Let me know if you need other info

-- 
Christian
Comment 5 Matěj Cepl 2010-02-26 07:16:12 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 6 Matěj Cepl 2010-05-10 19:10:47 EDT
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.
Comment 7 Igor Mammedov 2011-03-13 15:12:17 EDT
Got my hands on D201GLY again. FC14 system supplied driver doesn't work with it. Symptoms the same as in previous versions of sis driver (i.e. vertical stripes of noise on display).

After some searching, I've found driver that works with it, after commenting out lines: 3360-3363.

Download driver source and patches from:
http://aur.archlinux.org/packages.php?ID=34256&comments=all
Comment 8 Igor Mammedov 2011-03-13 15:26:18 EDT
Created attachment 484037 [details]
Patched driver that works with sis662 on Xorg 1.9

Patched and commented specified above lines. So that it won't be lost and would be easily found here by suffering D201GLY owners.
Comment 9 mdidomenico 2011-12-17 21:26:59 EST
Is there any chance that this could be backported to RHEL 6?  I have a few D201GLY boards with SIS vga chipset's that I use.  I've tried just about every recent distro Fedora 16, RHEL 6.2 Ubuntu 11.10(?), and debian.  All of them seem to suffer from the same vertical noise on the screen.

The vesa driver seems to clear the vertical noise, but does not allow me to spin up 1440x900 resolution (my monitor).

I have not been able to get the attached patched driver to compile, I'm missing some dependencies somewhere, which I cannot figure out.
Comment 10 valery.kirichenko 2011-12-23 16:26:50 EST
https://aur.archlinux.org/packages.php?ID=34256&comments=all
Working driver for RHEL 6.2
To get all dependencies,   try to compile sis driver from source.rpm for RHEL6.2 
rpmbuild -ba  xorg-x11-drv-sis.spec
and system ask you install all rpm you need and give you a list of rpm.
Comment 11 valery.kirichenko 2011-12-23 16:45:28 EST
Created attachment 549387 [details]
RHEL6.2 SiS662 x86_64 binary video driver from aur.archlinux.org
Comment 12 valery.kirichenko 2011-12-24 12:46:16 EST
Created attachment 549447 [details]
Total patch to compile SiS driver web24.server5.publicompserver.de/linux/sis/xf86-video-sis671-0.9.1.tar.gz on RHEL6.2 xorg 1.10.4

Summary of 6 patches from ??? people
2011-10-17
2011-03-06
2010-05-02
2010-02-02
2010-09-30
Comment 13 Fedora End Of Life 2013-04-03 15:58:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 14 Adam Jackson 2013-12-09 12:30:14 EST
*** Bug 651615 has been marked as a duplicate of this bug. ***
Comment 15 Fedora End Of Life 2015-01-09 16:39:37 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 16 Fedora End Of Life 2015-02-18 06:59:18 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.