Bug 504510 - xorg intel driver 2.7.0.7.fc11 generates strange Xorg log messages
xorg intel driver 2.7.0.7.fc11 generates strange Xorg log messages
Status: CLOSED DUPLICATE of bug 489907
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-07 14:50 EDT by Simone Deponti
Modified: 2009-10-27 13:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 13:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The X log (138.91 KB, text/plain)
2009-06-07 14:50 EDT, Simone Deponti
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21246 None None None Never

  None (edit)
Description Simone Deponti 2009-06-07 14:50:35 EDT
Created attachment 346788 [details]
The X log

Description of problem:
X, when compiz is enabled on GNOME, feels consistently slower than with Fedora 9 on the same machine. In addition, strange errors appears in Xorg.0.log:

(**) intel(0): Kernel mode setting active, disabling FBC.
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 4194303 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): max_gtt_map_size: 61727kb.
(II) intel(0): Tiled allocation successful.

And, subsequently through the whole file, seemingly random repetitions of:

(EE) intel(0): max_gtt_map_size: 61727kb.

This might be unrelated to the slowness, but that is what pèrompted me to investigate

Version-Release number of selected component (if applicable):
2.7.0.7.fc11

How reproducible:

Steps to Reproduce:
1. Log into X and activate desktop effects, checking that no xorg.conf is present
2. grep "(EE) " /var/log/Xorg.0.log
3.
  
Actual results:
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): max_gtt_map_size: 61727kb.
(EE) intel(0): max_gtt_map_size: 61727kb.
(EE) intel(0): max_gtt_map_size: 61727kb.
(EE) intel(0): max_gtt_map_size: 61727kb.
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): max_gtt_map_size: 59679kb.
(EE) intel(0): max_gtt_map_size: 59679kb.
(EE) intel(0): max_gtt_map_size: 59679kb.


Expected results:
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Additional info:
This is not a fatal bug, and the slowness is not enough to make the system unusable, however the error messages are somewhat odd (tiling fails on the front buffer: is it because the FBC was disabled?) and also because there is no trace of said errors launch in the vanilla 2.7.1 driver code from freedesktop's git: especially, all references to max_gtt_map_size are not there.
Comment 1 Simone Deponti 2009-06-07 17:25:12 EDT
Okay, this http://bugs.freedesktop.org/show_bug.cgi?id=21246#c3 might be related. The mentioned patch went upstream though, and should be in the current kernel I have installed (went upstream into 2.6.29.3, I'm on 2.6.29.4).

However, many other people report performance problems and they "disappeared" when switching to kernel 2.6.30 (http://beranger.org/v3/wordpress/2009/05/04/jaunty-kernel-2630-fixes-the-intel-video/). And in fact, 2.6.30 prepatch changelog does contain an awful lot of i915 fixes (http://kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.30-rc8), although my nonexistant knowledge doesn't allow me to say they solve the problem.

An update to 2.6.30 might solve this.
Comment 2 Bug Zapper 2009-06-09 13:12:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fabio Canepa 2009-07-03 08:31:28 EDT
I'm running fedora 11 with the latest kernel from koji (2.6.29.6-211.fc11.x86_64).
Inside /var/log/Xorg.0.log I see the error "(EE) intel(0): max_gtt_map_size: 60457kb" but now the performance is much more better!!
Before this kernel I'd to disable tiling (Option "Tiling" "false" inside /etc/X11/xorg.conf) to get a decent performance with desktop effect enabled...
Comment 4 Matěj Cepl 2009-07-03 11:22:30 EDT
(In reply to comment #3)
> I'm running fedora 11 with the latest kernel from koji
> (2.6.29.6-211.fc11.x86_64).
> Inside /var/log/Xorg.0.log I see the error "(EE) intel(0): max_gtt_map_size:
> 60457kb" but now the performance is much more better!!
> Before this kernel I'd to disable tiling (Option "Tiling" "false" inside
> /etc/X11/xorg.conf) to get a decent performance with desktop effect enabled...  

That error message is mostly harmless and red herring for most of the real problems.

So, can we say that this bug has been fixed by the kernel package 2.6.29.6-211.fc11.x86_64?
Comment 5 Simone Deponti 2009-07-03 11:53:03 EDT
Much faster but generate a kernel oops:
http://www.kerneloops.org/submitresult.php?number=509120
Comment 6 Matěj Cepl 2009-07-03 12:21:38 EDT
WARNING: at drivers/gpu/drm/i915/i915_gem_tiling.c:473 i915_gem_set_tiling+0x4a0/0x4f2 [i915]() (Not tainted)
Hardware name: 900
failed to unbind object for tiling switchModules linked in: bridge stp llc bnep sco l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 p4_clockmod ext2 dm_multipath uinput pcspkr joydev i2c_i801 iTCO_wdt iTCO_vendor_support uvcvideo videodev v4l1_compat usb_storage arc4 ecb ath5k snd_hda_codec_realtek mac80211 cfg80211 snd_hda_intel atl2 snd_hda_codec snd_hwdep snd_pcm snd_timer snd soundcore snd_page_alloc eeepc_laptop hwmon ata_generic pata_acpi i915 drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]
Pid: 1799, comm: Xorg Not tainted 2.6.29.6-211.fc11.i586 #1
Call Trace:
 [<c042ebc6>] warn_slowpath+0x7c/0xa4
 [<c0535db3>] ? selinux_capable+0xb4/0xc1
 [<c0705a10>] ? printk+0x14/0x1c
 [<f7f42193>] ? i915_gem_object_unbind+0x43/0x1f9 [i915]
 [<f7dbb405>] ? drm_gem_object_reference+0xd/0xf [drm]
 [<f7f46441>] i915_gem_set_tiling+0x4a0/0x4f2 [i915]
 [<f7dba602>] drm_ioctl+0x202/0x292 [drm]
 [<f7f45fa1>] ? i915_gem_set_tiling+0x0/0x4f2 [i915]
 [<c0532919>] ? inode_has_perm+0x60/0x6a
 [<c04461db>] ? getnstimeofday+0x59/0xea
 [<c04aa494>] vfs_ioctl+0x5a/0x74
 [<c04aad3d>] do_vfs_ioctl+0x480/0x4ba
 [<c0532ccf>] ? selinux_file_ioctl+0x3f/0x42
 [<c04aadbd>] sys_ioctl+0x46/0x66
 [<c0403f72>] syscall_call+0x7/0xb
---[ end trace 6f2ea718258f111d ]---
Comment 7 Fabio Canepa 2009-07-03 17:47:13 EDT
I didn't get the oops but I've booted only for some hours and I don't have selinux enabled (I see a selinux reference in the trace).
I found kernel 2.6.29.6-211.fc11.x86_64 faster on my card (i945GM)
Comment 8 Simone Deponti 2009-07-03 17:52:48 EDT
yes but my setup is different: for once you are using xorg.conf and I'm not, second you are on x86_64 and I'm on i586 (no PAE), and third, it's roughly 50% more fast with the new kernel, but gave me the oops (although the system did not crash).
Comment 9 Fabio Canepa 2009-07-03 18:12:22 EDT
Now I've delete the xorg.conf because it was created only to disable tiling and I still have a very good performance.But you are righ my setup it's different...
Comment 10 Antonio Trindade 2009-07-03 23:24:54 EDT
I'm having a similar problem but in my case the X freezes and it freezes the keyboard, also. I am not able to do anything unless i reboot the machine or connect through ssh.

Trace
 X: page allocation failure. order:1, mode:0x50d0
 Pid: 5129, comm: X Not tainted 2.6.29.5-191.fc11.i686.PAE #1
 Call Trace:
 [<c0714776>] ? printk+0x14/0x16
 [<c04840ff>] __alloc_pages_internal+0x36b/0x386
 [<c048415e>] __get_free_pages+0x19/0x29
 [<c04a2f87>] __kmalloc+0x2d/0x11d
 [<c05df34e>] agp_alloc_page_array+0x2a/0x45
 [<c05df3a7>] agp_generic_alloc_user+0x3e/0xa1
 [<c05df4bb>] agp_allocate_memory+0x3c/0xc1
 [<f81bf37d>] drm_agp_allocate_memory+0xd/0xf [drm]
 [<f81bf4bc>] drm_agp_bind_pages+0x3e/0xb0 [drm]
 [<f82b63ea>] i915_gem_object_bind_to_gtt+0x1a7/0x20a [i915]
 [<f82b646e>] i915_gem_object_pin+0x21/0x139 [i915]
 [<f81bb895>] ? drm_gem_object_lookup+0x35/0x3d [drm]
 [<f82b7941>] i915_gem_execbuffer+0x327/0xb37 [i915]
 [<f81ba73f>] drm_ioctl+0x202/0x292 [drm]
 [<f82b761a>] ? i915_gem_execbuffer+0x0/0xb37 [i915]
 [<c042e832>] ? default_wake_function+0x0/0x12
 [<c0426b5d>] ? __wake_up_common+0x39/0x61
 [<c04b2652>] vfs_ioctl+0x5c/0x76
 [<c04b2f06>] do_vfs_ioctl+0x480/0x4ba
 [<c04306cd>] ? finish_task_switch+0x34/0x9f
 [<c0439fca>] ? __do_softirq+0x12a/0x139
 [<c046bd02>] ? audit_syscall_entry+0x163/0x185
 [<c04b2f86>] sys_ioctl+0x46/0x66
 [<c040945f>] sysenter_do_call+0x12/0x34
Comment 11 Matěj Cepl 2009-10-27 13:44:08 EDT

*** This bug has been marked as a duplicate of bug 489907 ***

Note You need to log in before you can comment on or make changes to this bug.