Bug 504569 - F11 Blocker: Anaconda crash with dump
F11 Blocker: Anaconda crash with dump
Status: CLOSED DUPLICATE of bug 501768
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
urgent Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 05:34 EDT by Amit Shah
Modified: 2009-06-08 09:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 09:48:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (58.57 KB, text/plain)
2009-06-08 05:35 EDT, Amit Shah
no flags Details
anaconda.log (3.83 KB, text/plain)
2009-06-08 05:36 EDT, Amit Shah
no flags Details
syslog (41.80 KB, text/plain)
2009-06-08 05:36 EDT, Amit Shah
no flags Details
storage.log (3.85 KB, text/plain)
2009-06-08 05:37 EDT, Amit Shah
no flags Details
program.log (239 bytes, text/plain)
2009-06-08 05:37 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2009-06-08 05:34:35 EDT
Description of problem:
Downloaded the F11 (-rc4) DVD x86-64 iso image. This is an intel desktop.

The graphical installer shows an 'exception occurred' window, prompts to save the BR. When I click on 'save', a new pop-up says 'Finding storage devices...' and never goes away. I can't find a br from there. Dropping to the shell, I can see a few things.

I'll upload a few files from /tmp/ that'll show the crash.

Dumping the crash log here as well for convenience

anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 142, in duplicate
    return Disk(PedDisk=self.__disk.duplicate())
  File "/usr/lib/anaconda/storage/devices.py", line 740, in __init__
    self._origPartedDisk = self.partedDisk.duplicate()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1112, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1194, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1691, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 302, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 102, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartedException: Assertion (!disk->update_mode) at disk.c:421 in function ped_disk_destroy() fai
led.

Local variables in innermost frame:
self: parted.Disk instance --
  type: msdos  primaryPartitionCount: 3
  lastPartitionNumber: 10  maxPrimaryPartitionCount: 4
  partitions: [<parted.partition.Partition object at 0x7ff86e850f10>, <parted.partition.Partitio
n object at 0x7ff86e850fd0>, <parted.partition.Partition object at 0x7ff86e85a250>, <parted.part
ition.Partition object at 0x7ff86e85a3d0>, <parted.partition.Partition object at 0x7ff86e85a590>
, <parted.partition.Partition object at 0x7ff86e85a750>, <parted.partition.Partition object at 0
x7ff86e85a050>, <parted.partition.Partition object at 0x7ff86e85a950>, <parted.partition.Partiti
on object at 0x7ff86e85ab10>]
  device: <parted.device.Device object at 0x7ff86e8c6fd0>
  PedDisk: <_ped.Disk object at 0x7ff86e84f290>
Comment 1 Amit Shah 2009-06-08 05:35:27 EDT
Created attachment 346843 [details]
anacdump.txt
Comment 2 Amit Shah 2009-06-08 05:36:15 EDT
Created attachment 346844 [details]
anaconda.log
Comment 3 Amit Shah 2009-06-08 05:36:44 EDT
Created attachment 346845 [details]
syslog
Comment 4 Amit Shah 2009-06-08 05:37:19 EDT
Created attachment 346846 [details]
storage.log
Comment 5 Amit Shah 2009-06-08 05:37:57 EDT
Created attachment 346847 [details]
program.log
Comment 6 Chris Lumens 2009-06-08 09:48:58 EDT

*** This bug has been marked as a duplicate of bug 501768 ***

Note You need to log in before you can comment on or make changes to this bug.