Bug 504604 - virtinst ignores VirtualDisk(sparse = False) and doesn't pre-allocate the disk image
virtinst ignores VirtualDisk(sparse = False) and doesn't pre-allocate the dis...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-08 09:40 EDT by Mark McLoughlin
Modified: 2009-09-03 15:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 15:03:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-06-08 09:40:29 EDT
python-virtinst-0.400.3-8.fc11.noarch

If you use e.g. virt-install --nonsparse, notice that the disk image isn't pre-allocated.

This is due to:

    if self.sparse:
        alloc = 0
    else:
        #alloc = cap
        # XXX: disable setting managed storage as nonsparse
        # XXX: since it hoses libvirtd (for now)
        alloc = 0

This is removed upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/e34de678f53a

It looks like it needs this libvirt-0.6.3 change:

http://git.et.redhat.com/?p=libvirt.git;a=commitdiff;h=5aed3bcdda

So we can:

  a) backport the libvirt commit to F-11 and re-enable nonsparse in
     virtinst or

  b) just move this bug to F-12 and close when F-12 gets the next
     virtinst release
Comment 1 Cole Robinson 2009-09-03 15:03:26 EDT
Since I haven't heard any complaints about forcing sparse files, I think we can just closed this as current release for F12. The libvirt change is fairly sized, so I don't think the backport and coordinated updates are worth it.

Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.