Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 504650 - If expiration is set on a message published with a ttl, don't reset it
If expiration is set on a message published with a ttl, don't reset it
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
medium Severity low
: 1.1.2
: ---
Assigned To: Gordon Sim
Jan Sarenik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 13:04 EDT by Gordon Sim
Modified: 2009-06-12 13:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 13:39:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test program (1.40 KB, text/x-c++src)
2009-06-08 13:36 EDT, Gordon Sim
no flags Details
Fix (888 bytes, patch)
2009-06-08 13:40 EDT, Gordon Sim
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1097 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging bug fixing update 2009-06-12 13:38:48 EDT

  None (edit)
Description Gordon Sim 2009-06-08 13:04:20 EDT
Description of problem:

The JMS client calculates the expiration of a message itself on sending the message. The broker should not overwrite the clients value.

Version-Release number of selected component (if applicable):

Since 1.1

How reproducible:

100%

Steps to Reproduce:
1. send message with both ttl and expiration set
2. subscrbe and receive message
3. check that expiration on received message is exactly the value that was sent
  
Actual results:

The broker recalculates the expiration.

Expected results:

The expiration should be identical to the value set on sent message.

Additional info:
Comment 1 Gordon Sim 2009-06-08 13:36:47 EDT
Created attachment 346899 [details]
Test program

Fails before fix with "Expiration did not match".
Comment 2 Gordon Sim 2009-06-08 13:40:23 EDT
Created attachment 346901 [details]
Fix
Comment 3 Gordon Sim 2009-06-08 14:37:51 EDT
Fixed on trunk as r782712.
Comment 4 Gordon Sim 2009-06-09 04:23:11 EDT
Fyi: arg::durable=true in test program was supposed to be arg::autoDelete=true. Doesn't affect the core purpose of the test, but as it is it leaves queues lying around.
Comment 5 Gordon Sim 2009-06-09 04:26:22 EDT
Fixed in qpidd-0.5.752581-13.el5
Comment 6 Gordon Sim 2009-06-09 07:55:49 EDT
On RHEL4 you will need CXXFLAGS=-I/usr/include/qpid-boost as usual in order to compile the cpp test.
Comment 7 Jan Sarenik 2009-06-09 08:08:34 EDT
Reproduced on 0.5.752581-5

Verified on -13, both archs, both RHELs.
Comment 9 errata-xmlrpc 2009-06-12 13:39:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1097.html

Note You need to log in before you can comment on or make changes to this bug.