Bug 504670 - Alter channel subscriptions page is broken
Alter channel subscriptions page is broken
Status: CLOSED DUPLICATE of bug 504652
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 14:36 EDT by Jay Dobies
Modified: 2009-06-08 18:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 14:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2009-06-08 14:36:01 EDT
Description of problem:
Page throws ISE.

Version-Release number of selected component (if applicable):
Any Spacewalk/Satellite build after 6/1/09

How reproducible:
Always

Steps to Reproduce:
1. Click on the SDC > Alter Channel Subscriptions
  
Actual results:
ISE (detail below)

Expected results:
Alter channel subs page

Additional info:
Looks like it was a result of the schema change 121-rhnReleaseChannelMap.sql. In that change, the rhnReleaseChannelMap is_default column was removed. However, at least one of the queries that the alter channel subscriptions page setup uses (Channel_queries.base_eus_channels_by_version_channel_arch) still references the is_default column, causing an exception reading:

java.sql.SQLException: ORA-00904: "RCM"."IS_DEFAULT": invalid identifier
Comment 1 Jay Dobies 2009-06-08 14:43:24 EDT
The real issue here is that I need to learn how to search bugzilla better. Already filed as 504652.

*** This bug has been marked as a duplicate of bug 504652 ***

Note You need to log in before you can comment on or make changes to this bug.