Bug 504715 - ipa-nis-manage generates error
ipa-nis-manage generates error
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
Depends On:
Blocks: 431020
  Show dependency treegraph
Reported: 2009-06-08 19:18 EDT by Yi Zhang
Modified: 2015-01-04 18:39 EST (History)
3 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-03-27 03:14:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Yi Zhang 2009-06-08 19:18:35 EDT
Description of problem:

error message generates after "ipa-nis-manage" executes

Traceback (most recent call last):
  File "/usr/sbin/ipa-compat-manage", line 154, in ?
  File "/usr/sbin/ipa-compat-manage", line 134, in main
    conn.deleteEntry("cn=Schema Compatibility,cn=plugins,cn=config")
  File "/usr/lib/python2.4/site-packages/ipaserver/ipaldap.py", line 553, in deleteEntry
    self.__handle_errors(e, **kw)
  File "/usr/lib/python2.4/site-packages/ipaserver/ipaldap.py", line 324, in __handle_errors
    raise errors.DatabaseError(desc=desc,info=info)
ipalib.errors.DatabaseError: Operation not allowed on non-leaf:
This setting will not take effect until you restart Directory Server.

The problem is that I can only reproduce this with my tet automate script, When I run "ipa-nis-manage" manually, it works fine. 

Of course, this error cause most of my nis acceptance test failed. 

Version-Release number of selected component (if applicable): ipa daily build (June 8, 2009)

How reproducible: each time I run  nis test script  

Steps to Reproduce:
1. follow the tet automation procedure.  
Additional info: I am still trying to find out the exact reproduce condition
Comment 1 Rob Crittenden 2010-02-03 16:28:39 EST
I can't duplicate this so it may be that it has already been addressed. Please re-open if it happens again.
Comment 2 Jenny Galipeau 2011-01-25 11:47:55 EST


# ipa-nis-manage 
You must specify one action, either enable or disable

# ipa-nis-manage enable
Directory Manager password: 

Enabling plugin
This setting will not take effect until you restart Directory Server.
The rpcbind service may need to be started.

# ipa-nis-manage disable
Directory Manager password: 

This setting will not take effect until you restart Directory Server.


Note You need to log in before you can comment on or make changes to this bug.