Bug 504766 - X crashes when trying to scan with any GUI app (hp 5370C)
X crashes when trying to scan with any GUI app (hp 5370C)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 05:41 EDT by Nicu Buculei
Modified: 2013-04-02 00:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 03:57:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (70.65 KB, text/plain)
2009-06-09 05:42 EDT, Nicu Buculei
no flags Details

  None (edit)
Description Nicu Buculei 2009-06-09 05:41:41 EDT
Description of problem: X.org crashes when trying to scan using a GUI application (tried with GnomeScan and xsane-gimp). This is using a HP 5370C scanner, with the avision backend.


How reproducible: always


Steps to Reproduce:
1. connect the scanner, it is recognised correctly
2. start either GnomeScan or the Acquire dialog in GIMP
3. press either "scan" or "preview" buttons
4. X will close itself to the GDM screen.
  
Actual results: X.org closes, any unsaved data is lost.


Expected results: even if the sane-backend is broken and crash, it should not take the entire X.org session with it


Additional info: using sanimage from the command line:
[nicu@hell Desktop]$ scanimage --format=tiff --resolution=300 > scan.tiffscanimage: received signal 15
scanimage: trying to stop scanner
scanimage: received signal 15
scanimage: aborting
Comment 1 Nicu Buculei 2009-06-09 05:42:45 EDT
Created attachment 346995 [details]
Xorg log file
Comment 3 Matěj Cepl 2009-11-05 13:31:05 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 4 Nicu Buculei 2009-11-06 03:57:25 EST
The bug was solved after some updates in Fedora 11 (I can't point exactly which). Also, works for me in F12 (rawhide). Closing

Note You need to log in before you can comment on or make changes to this bug.