Bug 504777 - virt-p2v can't create snapshot of root filesystem
virt-p2v can't create snapshot of root filesystem
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: virt-p2v (Show other bugs)
unspecified
i386 Linux
low Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 07:32 EDT by Andreas Manschke
Modified: 2011-08-30 06:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-30 06:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from virt-p2v.log and dmesg (27.00 KB, application/octet-stream)
2009-06-09 07:32 EDT, Andreas Manschke
no flags Details

  None (edit)
Description Andreas Manschke 2009-06-09 07:32:31 EDT
Created attachment 347007 [details]
Output from virt-p2v.log and dmesg

Description of problem:
Running virt-p2v 0.9.9 on a i386  200 GB PATA HDD without LVM results in error abort: 
Command failed:
mount '/dev/mapper/snapsda9' /mnt/root

The root filesystem resides on hda9 (sda9). Other entries in  /dev/mapper/ seem to be correct. Interesting messages from virt-p2v.log:

device-mapper: table: device 253:7 too small for target
device-mapper: table: 253:8: linear: dm-linear: Device lookup failed
device-mapper: ioctl: error adding target to table


Version-Release number of selected component (if applicable):


How reproducible:
Allways (on this machine)

Steps to Reproduce:
1. Boot virt-p2v CD
2. Specify network parameters
3. Specify disk parameters
  
Actual results:
virt-p2v aborts

Expected results:
virt-p2v starts transfering image and parameter file

Additional info:
Comment 1 Richard W.M. Jones 2009-06-09 08:30:09 EDT
I will go with the suspicion that this is because the
kernel used on the live CD is too old.  It needs updating
anyway -- the live CD is based on Fedora 8 -- so I will
make a new build available shortly.
Comment 2 Richard W.M. Jones 2009-06-09 08:42:28 EDT
Sorry, comment 1 is wrong.  The 0.9.9 live CD is
in fact based on Fedora 10.

However I will build a virt-p2v CD based on
Fedora 11 since it's just been released.
Comment 3 Richard W.M. Jones 2011-08-30 06:01:09 EDT
There is a new version of virt-p2v and virt-v2v:
http://libguestfs.org/virt-v2v/

Note You need to log in before you can comment on or make changes to this bug.