Bug 504787 - F11 - cannot boot 32bit PAE kernel guest under Qemu/KVM
F11 - cannot boot 32bit PAE kernel guest under Qemu/KVM
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-09 09:10 EDT by Joel
Modified: 2009-06-15 22:28 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.10.5-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 22:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the full boot of the SLES11 32bit PAE VM (544.23 KB, image/png)
2009-06-09 09:10 EDT, Joel
no flags Details

  None (edit)
Description Joel 2009-06-09 09:10:12 EDT
Created attachment 347019 [details]
screenshot of the full boot of the SLES11 32bit PAE VM

Description of problem:
In Fedora 11 32bit during installation of SLES11 32bit under Qemu/KVM, it uses the kernel-default kernel.  Somewhere during the install, the installer detects that it is running on PAE capable hardware so it decides to install the PAE kernel.  On first boot, it tries to boot the PAE kernel and hangs with the last message being:

Probing EDD (edd=off to disable)... ok

If instead during installation you force it to not install the PAE kernel, then all is fine.

Version-Release number of selected component (if applicable):
qemu-common-0.10.4-4.fc11.i586
qemu-img-0.10.4-4.fc11.i586
qemu-system-ppc-0.10.4-4.fc11.i586
qemu-system-x86-0.10.4-4.fc11.i586
kernel-2.6.29.4-167.fc11.i586

How reproducible:
Every single time.


Steps to Reproduce:
1. Install SLES11 32bit on Fedora 11 with KVM enabled.
2. After install, try to boot the SLES11 VM.
3. Watch it fail.
  
Actual results:
Hang early on boot.


Expected results:
No hang at all.

Additional info:
This is on a Thinkpad T61 with Intel(R) Core(TM)2 Duo CPU     T7300  @ 2.00GHz
Comment 1 Joel 2009-06-09 09:22:09 EDT
So I booted into my RHEL5.3 VM, and force installed the PAE kernel, and it also fails to boot.  In fact, all you see are the GRUB messages:

  Booting command-list

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.18-128.el5PAE ro root=/dev/VolGroup00/LogVol00 console=ttyS
0
   [Linux-bzImage, setup=0x1e00, size=0x1bb6f4]
initrd /initrd-2.6.18-128.el5PAE.img
   [Linux-initrd @ 0xfcd1000, 0x30e286 bytes]


And nothing else is printed from the VM.
Comment 2 Joel 2009-06-09 10:42:52 EDT
Last bit of info I was able to get was while booting with 'earlyprintk=ttyS0'.  It gives a bit more output:

Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.27.19-5-pae (geeko@buildhost) (gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux) ) #1 SMP 2009-02-28 04:40:21 +0100
PAT WC disabled due to known CPU erratum.
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
 BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
 BIOS-e820: 000000000fff0000 - 0000000010000000 (ACPI data)
 BIOS-e820: 00000000fffbc000 - 0000000100000000 (reserved)
console [earlyser0] enabled
DMI 2.4 present.
last_pfn = 0xfff0 max_arch_pfn = 0x1000000
NX (Execute Disable) protection: active
RAMDISK: 0fa37000 - 0ffdf26e


And for the RHEL5.3 guest:

Uncompressing Linux... Ok, booting the kernel.
Linux version 2.6.18-128.el5PAE (mockbuild@hs20-bc1-5.build.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)) #1 SMP Wed Dec 17 12:02:33 EST 2008
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
 BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
 BIOS-e820: 000000000fff0000 - 0000000010000000 (ACPI data)
 BIOS-e820: 00000000fffbc000 - 0000000100000000 (reserved)
early console enabled
0MB HIGHMEM available.
255MB LOWMEM available.
found SMP MP-table at 000fbd10
Memory for crash kernel (0x0 to 0x0) notwithin permissible range
disabling kdump
NX (Execute Disable) protection: active
Comment 3 Glauber Costa 2009-06-10 11:33:27 EDT
This probably happens because your host is not PAE capable. If this is the case, it should be fixed by recent patches of cpuid trimming.

Please try a newer version of qemu.
http://koji.fedoraproject.org/koji/buildinfo?buildID=104657
Comment 4 Joel 2009-06-11 07:29:38 EDT
Updating to:
qemu-system-x86-0.10.5-2.fc11.i586
qemu-img-0.10.5-2.fc11.i586
qemu-common-0.10.5-2.fc11.i586
qemu-system-ppc-0.10.5-2.fc11.i586

does get the PAE guests running w/o issues.
Comment 5 Mark McLoughlin 2009-06-12 03:16:14 EDT
Thanks for testing, Joel
Comment 6 Fedora Update System 2009-06-15 22:28:21 EDT
qemu-0.10.5-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.