Bug 50481 - Reisferfs root filesystem fails to mount when reiserfs-utils package installed
Reisferfs root filesystem fails to mount when reiserfs-utils package installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: reiserfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-31 12:14 EDT by john.l.villalovos
Modified: 2013-07-02 22:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 11:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.l.villalovos 2001-07-31 12:14:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)

Description of problem:
/etc/rc.d/rc.sysinit run fsck on the root filesystem on bootup.  If the filesystem is a reisferfs file system and the reiserfs-utils package is
installed the system will hang on boot up.  This is because the reiserfs fsck program is waiting for the user to type Yes.

Recommend fsck not be run on reiserfs or determine way to run it so that it doesn't pause waiting for input.

How reproducible:
Always

Steps to Reproduce:
1.  Setup reiserfs on root ( / ) partition
2.  Install reiserfs-utils
3.  Reboot
	

Actual Results:  System hangs on reboot at checking root filesystem.

Expected Results:  System should have checked file system and continued with booting process.

Additional info:
Comment 1 Bill Nottingham 2001-07-31 12:23:36 EDT
if reiserfsck doesn't DTRT when it's called on a clean reiserfs FS, it's broken.
Comment 2 Need Real Name 2001-11-16 13:37:20 EST
'man reiserfsck' says:

  Since reiserfs is a journalling filesystem, you will not 
  normally use reiserfsck: if the filesystem is not cleanly 
  unmounted, the kernel will bring it to the consistent state 
  by replaying journal when you mount the filesystem. You 
  should apply reiserfsck ONLY if you suspect that filesystem 
  structure is broken....

So while one might argue that reiserfsck should behave 
differently, rc.sysinit should definitely NOT invoke it.
Comment 3 Tomas Mraz 2005-04-22 11:58:35 EDT
This seems to be fixed at least in FC3 if not earlier.

Note You need to log in before you can comment on or make changes to this bug.