Bug 504813 - manpage change: remove unimplemented mupdate_port from cyrus-imapd
manpage change: remove unimplemented mupdate_port from cyrus-imapd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cyrus-imapd (Show other bugs)
7.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Pavel Zhukov
Karel Volný
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 11:19 EDT by Karel Volný
Modified: 2017-08-01 12:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: cyrus-imapd-2.4.17-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-06-09 11:19:23 EDT
Description of problem:
If mupdate master is configured to listen on non-default port, the client cannot connect because it tries connecting on default port, despite mupdate_port being configured to match the server port.

Version-Release number of selected component (if applicable):
cyrus-imapd-2.3.7-6.el5

How reproducible:
always

Steps to Reproduce:
1. reconfigure mupdate port on master, i.e.
[root@dell-pesc430-01 ~]# diff bak/cyrus.conf /etc/cyrus.conf
29a30,31
>
> mupdate       cmd="mupdate -m" listen=2004 prefork=1

2. (on master) service cyrus-imapd start

3. reconfigure mupdate port on client, i.e.
[root@dell-pe1850-01 ~]# diff bak/cyrus.conf /etc/cyrus.conf
29a30,31
>
> mupdate       cmd="mupdate" listen=2004 prefork=1
[root@dell-pe1850-01 ~]# diff bak/imapd.conf /etc/imapd.conf
11a12,18
> mupdate_server: dell-pesc430-01.rhts.bos.redhat.com
> mupdate_config: standard
> mupdate_authname: cyrus
> mupdate_username: cyrus
> mupdate_password: password
> proxyservers: murder
> mupdate_port: 2004

4. (on client) service cyrus-imapd start

5. (on client) see /var/log/maillog
  
Actual results:
Jun  9 11:09:38 dell-pe1850-01 mupdate[30759]: connect(dell-pesc430-01.rhts.bos.redhat.com) failed: Connection refused
Jun  9 11:09:38 dell-pe1850-01 mupdate[30759]: couldn't connect to mupdate server
Jun  9 11:09:38 dell-pe1850-01 mupdate[30759]: retrying connection to mupdate server in 29 seconds
Jun  9 11:09:38 dell-pe1850-01 mupdate[30754]: connect(dell-pesc430-01.rhts.bos.redhat.com) failed: Connection refused
Jun  9 11:09:38 dell-pe1850-01 mupdate[30754]: couldn't connect to mupdate server
Jun  9 11:09:38 dell-pe1850-01 mupdate[30754]: retrying connection to mupdate server in 22 seconds


Expected results:
(no errors reported, connection established)

Additional info:
tcpdump output:

11:09:38.418861 IP dell-pe1850-01.rhts.bos.redhat.com.32909 > dell-pesc430-01.rhts.bos.redhat.com.mupdate: S 3447223187:3447223187(0) win 5840 <mss 1460,sackOK,timestamp 4012325 0,nop,wscale 7>
11:09:38.419087 IP dell-pesc430-01.rhts.bos.redhat.com.mupdate > dell-pe1850-01.rhts.bos.redhat.com.32909: R 0:0(0) ack 3447223188 win 0
11:09:38.420001 IP dell-pe1850-01.rhts.bos.redhat.com.32910 > dell-pesc430-01.rhts.bos.redhat.com.mupdate: S 3461516534:3461516534(0) win 5840 <mss 1460,sackOK,timestamp 4012326 0,nop,wscale 7>
11:09:38.420136 IP dell-pesc430-01.rhts.bos.redhat.com.mupdate > dell-pe1850-01.rhts.bos.redhat.com.32910: R 0:0(0) ack 3461516535 win 0
11:09:43.418452 arp who-has dell-pesc430-01.rhts.bos.redhat.com tell dell-pe1850-01.rhts.bos.redhat.com
11:09:43.418608 arp reply dell-pesc430-01.rhts.bos.redhat.com is-at 00:12:3f:73:7d:9d (oui Unknown)
11:10:00.427498 IP dell-pe1850-01.rhts.bos.redhat.com.32911 > dell-pesc430-01.rhts.bos.redhat.com.mupdate: S 3472040576:3472040576(0) win 5840 <mss 1460,sackOK,timestamp 4034334 0,nop,wscale 7>
11:10:00.427610 IP dell-pesc430-01.rhts.bos.redhat.com.mupdate > dell-pe1850-01.rhts.bos.redhat.com.32911: R 0:0(0) ack 3472040577 win 0
11:10:05.426934 arp who-has dell-pe1850-01.rhts.bos.redhat.com tell dell-pesc430-01.rhts.bos.redhat.com
11:10:05.426950 arp reply dell-pe1850-01.rhts.bos.redhat.com is-at 00:11:43:d2:c0:60 (oui Unknown)
11:10:07.426074 IP dell-pe1850-01.rhts.bos.redhat.com.32912 > dell-pesc430-01.rhts.bos.redhat.com.mupdate: S 3484019841:3484019841(0) win 5840 <mss 1460,sackOK,timestamp 4041333 0,nop,wscale 7>
11:10:07.426196 IP dell-pesc430-01.rhts.bos.redhat.com.mupdate > dell-pe1850-01.rhts.bos.redhat.com.32912: R 0:0(0) ack 3484019842 win 0
11:13:13.941924 IP dell-pesc430-01.rhts.bos.redhat.com.mdns > 224.0.0.251.mdns:  0*- [0q] 2/0/0 PTR[|domain]
Comment 1 Michal Hlavinka 2009-06-10 06:24:54 EDT
I've tested this:

1) disable selinux (setenforce 0) OR enable 2004 port for cyrus: semanage port -a -t cyrus_port_t -p tcp 2004

2) service cyrus-imapd restart
3) netstat -lpn | grep 2004
cyrus is bind to port 2004

4) tcpdump -vv | grep -e mupdate -e 2004 -e 3905
> client tries to connect to mupdate port instead of port 2004

client ignores mupdate_port from config file, it even seems this was never used??? because there is only one line in the whole sources ( grep -i -r mupdate_port cyrus-imapd-2.3.7/ ): 
cyrus-imapd-2.3.14/lib/imapopts.h:  IMAPOPT_MUPDATE_PORT,
^^^ just an item in enum
cyrus-imapd-2.3.14/lib/imapopts.c:  { IMAPOPT_MUPDATE_PORT, "mupdate_port", 0, (union config_value)((long) 3905), OPT_INT, {  { NULL, IMAP_ENUM_ZERO } } },

mupdate-client.c:
backend_connect(NULL, server, &mupdate_protocol,....
-> getaddrinfo(server, mupdate_protocol->service, &hints, &res0);

where mupdate_protocol->service = "mupdate" set in mupdate-client.c


In latest sources (Fedora 11 has cyrus-imapd 2.3.14) there is no change.
Comment 2 Michal Hlavinka 2009-06-10 06:29:03 EDT
this is more like feature request because it seems this was never working...
Comment 7 RHEL Product and Program Management 2009-11-06 14:02:24 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 RHEL Product and Program Management 2010-08-09 15:10:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2011-01-11 15:23:22 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2011-01-11 17:26:34 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 18 RHEL Product and Program Management 2011-09-22 20:12:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 19 RHEL Product and Program Management 2012-06-11 21:03:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 20 Michal Hlavinka 2013-03-15 11:27:31 EDT
Does not meet criteria for RHEL5 - phase 2 support, moving to RHEL 6.
Comment 22 RHEL Product and Program Management 2013-10-13 21:24:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 24 Tomáš Hozza 2016-08-17 11:45:11 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

Moving to RHEL-7
Comment 32 errata-xmlrpc 2017-08-01 12:22:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1932

Note You need to log in before you can comment on or make changes to this bug.