Bug 504831 - Can't install Fedora 11 to single partition
Can't install Fedora 11 to single partition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 13:11 EDT by Alberto Gonzalez
Modified: 2009-06-10 14:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 15:02:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alberto Gonzalez 2009-06-09 13:11:07 EDT
Description of problem:

I have a free primary partition where I'd like to install Fedora to. Installing from a live CD it is impossible. Catch 22 kind of problem.

If I select ext3 as the filesystem, I get a cryptic message saying: "Your / partition does not match the the live image you are installing from. It must be formatted as ext4."

What does this mean??? I know that Fedora 11 wanted to default to ext4. That's fine. But what's that _forcing_ you to use ext4? Besides, what does it mean that my root partition does not match the live image? I'm installing from a USB stick formatted as FAT 32, anyway. And why would it matter? I want to copy that image into an ext3 formatted partition, what's the problem?

Ok, so I gave in and decided to choose ext4 as my root filesystem. And then I got this message: "Bootable partitions cannot be on an ext4 filesystem". Nice.

So I need 2 partitions to install Fedora: one MUST be ext3 for /boot and the other MUST be ext4 for /. But I don't have 2 free primary partitions and I dislike logical partitions - not that it matters, that's not the point anyway. The point is: there is a critical bug preventing me from installing Fedora the way I installed all previous Fedoras and every other distro I've ever known. And not that it's a weird kind of installation that I chose. It's just a simple "install Fedora into this partition I have free for it" kind of installation.


How reproducible: Always.


Steps to Reproduce:
1. Get live CD
2. Try to install it into a single partition
  
Actual results:
Won't let you do it. No matter the filesystem you choose.

Expected results:
It should let you install it into _one_ partition. Moreover, it should let you choose the filesystem to use (but that's even secondary to the critical bug of not allowing to install at all).

Additional info:
Comment 1 Jeremy Katz 2009-06-09 15:02:54 EDT
Yes, with Fedora 11 to install from the live image, you have to have two partitions.  This is because we have switched to ext4 as the default filesystem and thus it is used for the rootfs.  Unfortunately, the support for ext4 in grub was not ready in time and so you need to have a /boot that's of a filesystem type that grub can boot from (eg, ext3).

The filesystem you install to from the live image has to match as we end up just copying the filesystem off of the live image and resizing it to fit your partition.

Fedora 12 will have the grub patches and will then be able to be installed in a single partition again from the live media.  Until then, if you want to install to a single partition, you have to do so from the DVD install media.
Comment 2 Alberto Gonzalez 2009-06-09 17:41:18 EDT
Ok, thanks for the explanation. Just some notes:

- I've been using grub on an ext4 partition for 5 months now in Arch Linux. They have it patched there since then. It's strange that Fedora 11 still didn't get that patch, especially when it wants to push ext4 as the default filesystem. Here is the 5 months old patch (for reference, at least):

http://repos.archlinux.org/viewvc.cgi/grub/repos/core-x86_64/ext4.patch?revision=23005

- Why on earth using Fedora live media for installing you can't choose the filesystem? It is the first time I see this shortcoming. Maybe it is not a bug per se, since it is intended. It is just the wrong way of doing it. With any other live CD you can choose the filesystem, and that's how it should be. The same way I can copy a file from an XFS partition to an Ext4 partition without a problem, why shouldn't I be able to copy the live image to a partition with a filesystem of my liking? This IS a problem, even when in Fedora 12 you finally patch grub to allow to install to a single partition. You'll be forcing users to download a whole DVD just to choose a filesystem different from Ext4.

Thanks.
Comment 3 Jeremy Katz 2009-06-10 14:18:01 EDT
(In reply to comment #2)
> - Why on earth using Fedora live media for installing you can't choose the
> filesystem? It is the first time I see this shortcoming. Maybe it is not a bug
> per se, since it is intended. It is just the wrong way of doing it. With any
> other live CD you can choose the filesystem, and that's how it should be. The
> same way I can copy a file from an XFS partition to an Ext4 partition without a
> problem, why shouldn't I be able to copy the live image to a partition with a
> filesystem of my liking?

Because you can't just copy filesystems like that.  Sure, we could do a deep copy of every file on the filesystem, but its *orders of magnitude* slower to do so.  A block based copy of the filesystem image is substantially faster and the way the live installer in Fedora has always worked.  It's not "wrong", just "different".  

> This IS a problem, even when in Fedora 12 you finally
> patch grub to allow to install to a single partition. You'll be forcing users
> to download a whole DVD just to choose a filesystem different from Ext4.

The live image is set up with a lot of defaults and doesn't allow you to customize a lot of things that you can in a more general case.  This is by design.  The boot.iso for a network installation or the DVD both allow you to customize things as much as you want.

Note You need to log in before you can comment on or make changes to this bug.