Bug 504889 - Anaconda crash upon starting
Anaconda crash upon starting
Status: CLOSED DUPLICATE of bug 501768
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:037ea2ffca2e1969f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 18:35 EDT by Michael Haworth
Modified: 2009-06-10 11:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 11:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (15.74 KB, text/plain)
2009-06-09 18:35 EDT, Michael Haworth
no flags Details
Screenshot of error (114.74 KB, image/png)
2009-06-09 18:40 EDT, Michael Haworth
no flags Details

  None (edit)
Description Michael Haworth 2009-06-09 18:35:05 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59-1.fc11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 142, in duplicate
    return Disk(PedDisk=self.__disk.duplicate())
  File "/usr/lib/anaconda/storage/devices.py", line 740, in __init__
    self._origPartedDisk = self.partedDisk.duplicate()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1112, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1194, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1691, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 302, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 73, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartedException: Assertion (!disk->update_mode) at disk.c:421 in function ped_disk_destroy() failed.
Comment 1 Michael Haworth 2009-06-09 18:35:21 EDT
Created attachment 347108 [details]
Attached traceback automatically from anaconda.
Comment 2 Michael Haworth 2009-06-09 18:40:02 EDT
Created attachment 347109 [details]
Screenshot of error
Comment 3 Chris Lumens 2009-06-10 11:03:52 EDT

*** This bug has been marked as a duplicate of bug 501768 ***

Note You need to log in before you can comment on or make changes to this bug.