Bug 504899 - mailx man page description doesn't match mailx implementation
mailx man page description doesn't match mailx implementation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mailx (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 20:46 EDT by JW
Modified: 2009-10-12 10:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 188313
Environment:
Last Closed: 2009-10-12 09:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2009-06-09 20:46:10 EDT
+++ This bug was initially created as a clone of Bug #188313 +++

Description of problem:
The options for mailx descriped in the mailx man page does not match the implementation of mailx.

Version-Release number of selected component (if applicable):
mailx-12.4-1

How reproducible:
always

Steps to Reproduce:
1. run "man mailx"
2. use that information to try to use /bin/mailx
3.
  
Actual results:

Many options fail.
For example, the "-e" option is described in the man page, but running "mailx -e" produces:
mailx: invalid option -- e
Usage: mail [-iInv] [-s subject] [-c cc-addr] [-b bcc-addr] to-addr ...
            [-- sendmail-options ...]
       mail [-iInNv] -f [name]
       mail [-iInNv] [-u user]

Expected results:
The options described in the mailx man page should match what the mailx program accepts.

Additional info:
Comment 1 Dmitry Butskoy 2009-06-16 10:12:02 EDT
Looks strange. Does "man mail" describe "-e" option as well or not?
("man mailx" refers to /usr/share/man/man1p/mailx.1p.gz from the "man-pages" package, whereas "man mail" refers to own mailx's manual /usr/share/man/man1/mail.1.gz)

What is your output of "which mailx" or "type mailx", and "rpm -qf /bin/mailx" ?
Comment 2 JW 2009-06-16 10:22:20 EDT
Do you have access to a Fedora system where you can check it out?
Comment 3 Dmitry Butskoy 2009-06-16 10:45:47 EDT
Sure! But on my system, it works fine... ;)
Comment 4 Walter Neumann 2009-10-12 09:15:55 EDT
I have the same problem. Turns out I am not using the mailx from the fedora package -- at some point in the distant past I'd installed another in /usr/local/bin when the fedora one crashed. Just checked the current fedora mailx and it seems fine.  I suspect JW's problem may be similar, in which case this is notabug.
Comment 5 JW 2009-10-12 10:01:32 EDT
It *was* a bug.

It was fixed in a previous version: somewhere just before 12.4-1 and possibly as a result of this bug report.

So please amend from NOTABUG to CURRENTRELEASE or just plain RESOLED (there should be such a Status or dont bugs ever get fixed?)
Comment 6 Dmitry Butskoy 2009-10-12 10:11:47 EDT
For comment #5 :

> It was fixed in a previous version: somewhere just before 12.4-1

According to http://cvs.fedoraproject.org/viewvc/rpms/mailx/F-10/,
mailx in F10 was last changed 14 months ago (ie. in August 2008), whereas your bug report about F10's mailx is dated at  2009-06-09 ...

Note You need to log in before you can comment on or make changes to this bug.