Bug 504908 - XFCE does not keep the display settings after each logout
XFCE does not keep the display settings after each logout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-settings (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 22:11 EDT by Paul Smith
Modified: 2009-10-27 03:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.6.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 03:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 5445 None None None Never

  None (edit)
Description Paul Smith 2009-06-09 22:11:47 EDT
Whenever I set my display to the resolution

1024 x 768,

after a logout this setting is lost.

Paul
Comment 1 Paul Smith 2009-06-09 22:16:14 EDT
I do not know whether the following is related. When I try to activate the xscreensaver (from the screensaver window), I get the following error:

"The XScreenSaver daemon doesn't seem to be running
on display ":0.0".  Launch it now?"

and then, when I launch it, I get

"The xscreensaver daemon did not start up properly.

Please check your $PATH and permissions."

Paul
Comment 2 Kevin Fenzi 2009-06-09 23:58:47 EDT
I see other reports of this on the net...but nothing I can find in the upstream bugtracker. 

I'll look at filing a bug upstream. Thanks for the report and I will keep you posted on what I can find.
Comment 3 Kevin Fenzi 2009-06-10 00:16:19 EDT
Filed upstream. See attached bug link.
Comment 4 Paul Smith 2009-06-12 11:20:16 EDT
After Rex's comment, I installed system-config-display, which was not installed, and I configured my display with it. This procedure eliminated the reported problem. Now, I have everything working as expected.

I do not know why system-config-display was not installed by default.

Paul
Comment 5 Christoph Wickert 2009-09-09 20:03:05 EDT
I pretty sure that this is not an Xfce problem but somewhere deeper in X, Hal or whatever.

Paul, when you had this problem, was the resolution 1024x768 on the login screen and changed afterwards or was it wrong all the time?
Comment 6 Kevin Fenzi 2009-09-11 14:24:04 EDT
Xfce should restore whatever the user selected, in spite of this being different than the default. 

This seems to be fixed upstream in: 
http://git.xfce.org/xfce/xfce4-settings/commit/?h=xfce-4.6&id=837281a333935d022621841155207bd4c75f1731

I suppose we could look at backporting this to f11.
Comment 7 Paul Smith 2009-09-13 08:07:04 EDT
(In reply to comment #5)
> I pretty sure that this is not an Xfce problem but somewhere deeper in X, Hal
> or whatever.
> 
> Paul, when you had this problem, was the resolution 1024x768 on the login
> screen and changed afterwards or was it wrong all the time?  

Thanks, Christoph.

I have meanwhile replaced my previous monitor by a new one, and I cannot now remember well the situation. However, I do recall that the reported problem was solved by using system-config-display to configure the display.

Paul
Comment 8 Kevin Fenzi 2009-09-26 16:58:18 EDT
system-config-display would let you hardcode a specific non default resolution. ie, it would always be that resolution after you set it. 

The issue here is that you didn't want the default resolution, you wanted what you changed it to with the xfce display settings. The bug here is that it wouldn't remember and restore that setting when you logged in. (At least this is my understanding of the issue :) 

I just added a patch with the upstream commit that fixes this behavior. 
Testing very welcome.
Comment 9 Fedora Update System 2009-09-26 17:16:08 EDT
xfce4-settings-4.6.1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xfce4-settings-4.6.1-5.fc11
Comment 10 Fedora Update System 2009-09-29 10:32:31 EDT
xfce4-settings-4.6.1-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-settings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10045
Comment 11 Fedora Update System 2009-09-29 19:39:49 EDT
xfce4-settings-4.6.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xfce4-settings-4.6.3-1.fc11
Comment 12 Fedora Update System 2009-09-30 20:03:58 EDT
xfce4-settings-4.6.3-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-settings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10139
Comment 13 Fedora Update System 2009-10-27 03:07:07 EDT
xfce4-settings-4.6.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.