This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 504913 - F11 kickstart install fails on partition, "no preexisting VG..."
F11 kickstart install fails on partition, "no preexisting VG..."
Status: CLOSED DUPLICATE of bug 503681
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 22:24 EDT by Dennis Brylow
Modified: 2009-06-10 06:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 06:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file partition section. (658 bytes, text/plain)
2009-06-09 22:24 EDT, Dennis Brylow
no flags Details
Output of pvdisplay (392 bytes, text/plain)
2009-06-09 22:26 EDT, Dennis Brylow
no flags Details

  None (edit)
Description Dennis Brylow 2009-06-09 22:24:25 EDT
Created attachment 347135 [details]
kickstart file partition section.

Description of problem:
Pristine Fedora 11 install fails kickstart at partition stage.  States:
"Error parsing kickstart config. ... No preexisting VG with the name VolGroup00 was found."

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Start with Fedora 10 box with predefined partition scheme consisting of several partitions that should be preserved across an install.
2. Netboot machine with kickstart file containing partition scheme used in previous install.
3. Observe failure.
  
Actual results:
Error parsing kickstart file.  Then installer exits.

Expected results:
Normal kickstart install.

Additional info:

On the off chance that syntax for this has changed, I manually installed Fedora 11 on this machine, selecting "Custom Layout", and rebuilding my required partitioning scheme.  I then used the resulting, fresh anaconda.ks file generated by F11 to reattempt the kickstart install.  This also fails in similar fashion, implying that F11 cannot correctly read back its own anaconda.ks partitioning info under some circumstances.

Possibly unrelated, but I also note that the F11 anaconda.ks included the line "#clearpart --linux --drives=sda" which is not correct, is not what I did in the manual install, and certainly would do bad things if I included it.

I've got dozens of machines that use this partition scheme, so a fix for this would be very nice.  This kickstart partition table has worked correctly since at least Fedora 8 on this group of machines.

I'm attaching the partition scheme below, as well as a listing from pvdisplay from the machine when running.
Comment 1 Dennis Brylow 2009-06-09 22:26:13 EDT
Created attachment 347136 [details]
Output of pvdisplay
Comment 2 Radek Vykydal 2009-06-10 06:29:57 EDT
Thanks for report, you are most likely hitting a bug
that should be fixed in next anaconda build for rawhide.
(also see https://fedoraproject.org/wiki/Common_F11_bugs#503681).

*** This bug has been marked as a duplicate of bug 503681 ***

Note You need to log in before you can comment on or make changes to this bug.