This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 504924 - Segfaults when applying the patch
Segfaults when applying the patch
Status: CLOSED DUPLICATE of bug 498102
Product: Fedora
Classification: Fedora
Component: patch (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 23:25 EDT by Bojan Smojver
Modified: 2009-06-10 05:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 05:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2009-06-09 23:25:54 EDT
Description of problem:
Occasionally, it segfaults when applying the patch:
------------------------------
$ gdb patch
GNU gdb (GDB) Fedora (6.8.50.20090302-23.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Missing separate debuginfos, use: debuginfo-install patch-2.5.4-38.fc11.i586
(gdb) set args -p0 < ../../patches/apu-dbm-libs.patch
(gdb) r
Starting program: /usr/bin/patch -p0 < ../../patches/apu-dbm-libs.patch
warning: .dynamic section for "/lib/libc.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
patching file apu-config.in

Program received signal SIGSEGV, Segmentation fault.
0x00188ac8 in strcmp () from /lib/libc.so.6
(gdb) bt
#0  0x00188ac8 in strcmp () from /lib/libc.so.6
#1  0x080501ce in ?? ()
#2  0x00126a66 in __libc_start_main () from /lib/libc.so.6
#3  0x08049511 in geteuid ()
------------------------------

Version-Release number of selected component (if applicable):
2.5.4-38.fc11.i586

How reproducible:
Sometimes.

Steps to Reproduce:
1. Patch some source (in my case APU SVN working copy).
  
Actual results:
Sometimes segfaults.

Expected results:
Shouldn't segfault.

Additional info:
Yes, I loaded debuginfos after the crash. But, I was unable to reproduce this since.

Duplicate of bug #498102?
Comment 1 Tim Waugh 2009-06-10 05:12:26 EDT
Yes, looks like it.

*** This bug has been marked as a duplicate of bug 498102 ***

Note You need to log in before you can comment on or make changes to this bug.