Bug 504933 - Upgrade to F11 doesn't work with Macbook (possible KMS issue)
Upgrade to F11 doesn't work with Macbook (possible KMS issue)
Status: CLOSED DUPLICATE of bug 494390
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 23:52 EDT by James Morris
Modified: 2009-06-16 21:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 21:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo of screen (74.34 KB, image/jpeg)
2009-06-09 23:54 EDT, James Morris
no flags Details
xorg conf (2.19 KB, text/plain)
2009-06-14 19:46 EDT, James Morris
no flags Details
xorg log (64.03 KB, text/plain)
2009-06-14 19:47 EDT, James Morris
no flags Details
lspci -nn output (2.21 KB, text/plain)
2009-06-15 19:02 EDT, James Morris
no flags Details

  None (edit)
Description James Morris 2009-06-09 23:52:36 EDT
Description of problem:

I'm unable to get past one of the splash screens when upgrading an intel Macbook.  The cursor looks very strange and there are no navigation buttons.  It seems that the screen is at the wrong resolution.  I noticed some screen artifacts before this.  Currently upgrading with basic video driver with more success.

See the attached photo of the screen when things go wrong.

The cursor is the 3 black dots you can see on the right.

The lcd panel borders are roughly that of the photo (i.e. whatever is being displayed does not fill the display).
Comment 1 James Morris 2009-06-09 23:54:43 EDT
Created attachment 347140 [details]
photo of screen
Comment 2 Matěj Cepl 2009-06-12 12:17:02 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 James Morris 2009-06-14 19:46:03 EDT
I've since run x.org configuration and got things running manually (it worked fine like that, just not during install).

The basic video install left a simple vesa config, but when I configured it manually, the result was per the attached config file.  I've also attached the latest Xorg log (there's only one other, which is also from since the system was configured correctly -- there does not seem to be a log from the installation phase).
Comment 4 James Morris 2009-06-14 19:46:59 EDT
Created attachment 347869 [details]
xorg conf
Comment 5 James Morris 2009-06-14 19:47:28 EDT
Created attachment 347870 [details]
xorg log
Comment 6 Adam Williamson 2009-06-15 13:03:34 EDT
This looks rather like 494390 (and 505536). can we get lspci -nn ? I bet dollars to donuts the PCI ID for the gfx card is 8086:27A2 .

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 James Morris 2009-06-15 19:02:47 EDT
Created attachment 348027 [details]
lspci -nn output

Enjoy your donuts.
Comment 8 Adam Williamson 2009-06-16 21:09:12 EDT
mmmm...donuts...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 494390 ***

Note You need to log in before you can comment on or make changes to this bug.