Bug 504934 - Dual monitor setup not working
Dual monitor setup not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 00:07 EDT by Kyle Brantley
Modified: 2009-08-23 23:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-23 23:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (269.02 KB, text/plain)
2009-06-10 00:08 EDT, Kyle Brantley
no flags Details
lspci (18.06 KB, text/plain)
2009-06-10 00:08 EDT, Kyle Brantley
no flags Details
xorg conf (536 bytes, text/plain)
2009-06-10 00:09 EDT, Kyle Brantley
no flags Details
picture of working monitor (1.18 MB, image/jpeg)
2009-06-10 00:11 EDT, Kyle Brantley
no flags Details
picture of second (broke) monitor (1.44 MB, image/jpeg)
2009-06-10 00:11 EDT, Kyle Brantley
no flags Details
xorg log w/ kms (103.96 KB, text/plain)
2009-06-10 01:15 EDT, Kyle Brantley
no flags Details
dmesg w/ drm.debug=1 uscript=1, init 3 (123.42 KB, text/plain)
2009-06-10 01:16 EDT, Kyle Brantley
no flags Details
dmesg w/ drm.debug=1, kernel -201 (123.41 KB, text/plain)
2009-06-29 13:50 EDT, Kyle Brantley
no flags Details
Xorg.0.log with -201 (33.30 KB, text/plain)
2009-06-29 13:51 EDT, Kyle Brantley
no flags Details
wrong sized loading screen (1.02 MB, image/jpeg)
2009-06-29 14:00 EDT, Kyle Brantley
no flags Details
dmesg w/ drm.debug=1, kernel -205, working (194.58 KB, text/plain)
2009-06-30 15:40 EDT, Kyle Brantley
no flags Details

  None (edit)
Description Kyle Brantley 2009-06-10 00:07:47 EDT
Description of problem: I'm attempting to get two monitors to function in a "standard" LeftOf (or RightOf, however you please) configuration using nouveau and a GTX 260.

The first monitor, identified as DVI-I-0, works properly at its native resolution (1680x1050). The second monitor, identified as DVI-I-1, does not. Whenever -1 is enabled in any fashion, the monitor displays a partial mirror of -0, with a weird green overlay. Attached is a picture of this... oddity.

I've tried configuring -1 with xorg.conf, xrandr, krandrtray, KDE4's Display settings, and Gnome's display settings. The results are the same on all of them.

Version-Release number of selected component (if applicable):
-xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11.x86_64
-Linux desktop.averageurl.com 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux




How reproducible: Always


Steps to Reproduce:
1. (Assuming the second monitor is disabled) Enable the second monitor with any xrandr-type tool.
2. Observe the broken.
  
Actual results: See attached photo.


Expected results: I should be able to drag a window from one to the other.


Additional info: Attached is my lspci, xorg.conf, Xorg.0.log, and example picture.
Comment 1 Kyle Brantley 2009-06-10 00:08:27 EDT
Created attachment 347143 [details]
xorg log
Comment 2 Kyle Brantley 2009-06-10 00:08:53 EDT
Created attachment 347144 [details]
lspci
Comment 3 Kyle Brantley 2009-06-10 00:09:08 EDT
Created attachment 347145 [details]
xorg conf
Comment 4 Kyle Brantley 2009-06-10 00:11:12 EDT
Created attachment 347146 [details]
picture of working monitor
Comment 5 Kyle Brantley 2009-06-10 00:11:50 EDT
Created attachment 347147 [details]
picture of second (broke) monitor
Comment 6 Ben Skeggs 2009-06-10 00:51:15 EDT
Just some notes from working with Kyle on IRC so I don't forget:
 - booting with just the "bad" display connected works
 - VBIOS comes up on "good" display by default
 - kms and nv have the same problem
 - seems that non VBIOS-assisted outputs fail on this card too
 - enabling BIOS output script execution in kms mode fixes the problem.

Won't be able to enable nouveau.uscript=1 by default for a while yet, too little testing, and known broken cases.
Comment 7 Kyle Brantley 2009-06-10 01:15:47 EDT
Created attachment 347155 [details]
xorg log w/ kms
Comment 8 Kyle Brantley 2009-06-10 01:16:20 EDT
Created attachment 347156 [details]
dmesg w/ drm.debug=1 uscript=1, init 3
Comment 9 Ben Skeggs 2009-06-29 05:07:51 EDT
Hey, are you able to update to the kernel build from http://koji.fedoraproject.org/koji/buildinfo?buildID=112059 and ensure that the uscript code still works as expected for you?  There have been some significant changes to the code in that build.
Comment 10 Kyle Brantley 2009-06-29 13:44:52 EDT
No, it does not work as expected. One monitor simply stays off. That monitor, incidentally, is the one with the kdm login box. I'll be attaching a drm.debug=1 dmesg log + Xorg.0.log.
Comment 11 Kyle Brantley 2009-06-29 13:49:30 EDT
Okay, after rebooting back into -191, the second monitor still came up dead. Shut it off for a moment, booted into windows, both displays worked fine. Rebooted back into -191 and.. second monitor still dead.

Log files being attached now..
Comment 12 Kyle Brantley 2009-06-29 13:50:47 EDT
Created attachment 349835 [details]
dmesg w/ drm.debug=1, kernel -201
Comment 13 Kyle Brantley 2009-06-29 13:51:21 EDT
Created attachment 349837 [details]
Xorg.0.log with -201
Comment 14 Kyle Brantley 2009-06-29 14:00:08 EDT
Created attachment 349844 [details]
wrong sized loading screen

After swapping which DVI port the monitors are attached to, the larger monitor (which wasn't coming on) came alive just fine. The smaller monitor - which was working - didn't.

Further, the loading screen came up on the 1680x1050 monitor, but only rendered at 1440x900 (see attached picture - ignore the coloring, that's just a bad camera with lots of glare. The colors are correct).

This is on -191 after booting -201.
Comment 15 Kyle Brantley 2009-06-29 14:35:57 EDT
Dropping back to -167 (f11 stock release) resulted in a desktop that works.
Comment 16 Kyle Brantley 2009-06-30 15:40:54 EDT
Created attachment 350014 [details]
dmesg w/ drm.debug=1, kernel -205, working

I noticed -205 with a nouveau change - so I grabbed the source, tweaked the .config to give me a bigger dmesg log, rebuilt, installed, enabled drm.debug and...


... it worked great. Running said tweaked -205 now with no issues. Attached is the full (non-truncated!) dmesg.
Comment 17 Ben Skeggs 2009-06-30 18:05:43 EDT
Excellent, good to hear!  The info that -191 also didn't work was a good indication that there was yet more fallout from a DRM change that got pushed into F11 recently :)
Comment 18 Ben Skeggs 2009-08-23 23:35:50 EDT
Ok, I'll close this as fixed in rawhide.  Though you have tweaks to make it work now, it should JustWork(tm) out of the box in F12.

Note You need to log in before you can comment on or make changes to this bug.