Bug 504950 - [965GM] Massive video performance regression with F12 kernel and F11 packages
[965GM] Massive video performance regression with F12 kernel and F11 packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 03:34 EDT by Ravi Srinivasan
Modified: 2013-04-02 00:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 17:57:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravi Srinivasan 2009-06-10 03:34:16 EDT
Description of problem:
I was feeling very adventurous so I got the latest 2.6.30 rc from koji and installed it on my brand new f11 setup. I used glxgears as a high level video performance indicator and then use some avi videos and youtube for comparison

This is a thinkpad R61 with intel GM965 and Core 2. running F11 64-bit GNOME.

700 FPS with 2.6.29-4 (the one that came with F11 stock - .167.f11?)
200 FPS with 2.6.30-0.100.rc8.git6.fc12.x86_64!!

[ravis@tenken ~]$ glxgears
1381 frames in 5.0 seconds = 275.892 FPS
1266 frames in 5.0 seconds = 253.128 FPS

FYI - I ran a Debian 5 livecd and it can push 1000+ FPS. but we all know how the intel driver is borked for the time being and will take time to stabilize...here's hoping they fix it soon. Fedora's patched kernels should not add on the already existing poor performance - just my 2c


abysmal video performance. stuttering, stalling and unusable 

BTW - should i be even reporting koji build bugs here??

Version-Release number of selected component (if applicable):
kernel-doc-2.6.30-0.100.rc8.git6.fc12.noarch
kernel-devel-2.6.30-0.100.rc8.git6.fc12.x86_64
kernel-2.6.30-0.100.rc8.git6.fc12.x86_64
kernel-firmware-2.6.30-0.100.rc8.git6.fc12.noarch
kernel-headers-2.6.30-0.100.rc8.git6.fc12.x86_64


glibc-headers-2.10.1-2.x86_64
glibc-2.10.1-2.i686
glibc-common-2.10.1-2.x86_64
glibc-2.10.1-2.x86_64
glibc-devel-2.10.1-2.x86_64

xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
xorg-x11-server-common-1.6.1.901-1.fc11.x86_64


How reproducible:

Get latest 2.6.30 rc from koji. install and watch videos/youtube/3D apps

Steps to Reproduce:
1.
2.
3.
  
Actual results:
poor video and 3d performance. I am assuming kernel caused the regression since the intel video driver version is the same as in the old version. all other versions remain the same from F11 stock

Expected results:

improved or equal performance as in F11 stock or older releases

Additional info:
Comment 1 Brian Millett 2009-09-07 17:34:19 EDT
upgraded to kernel-PAE-devel-2.6.30.5-43.fc11.i686.

The video performance is very bad.  Made my eyes bleed.

Dell d820 Fedora 11
nvidia-x11-drv-190.18-1.fc11.i586

lspci -vv

01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Dell Device 01cc
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at ed000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at ee000000 (64-bit, non-prefetchable) [size=16M]
	[virtual] Expansion ROM at ef000000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <256ns, L1 <4us
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
			ClockPM- Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [128] Power Budgeting <?>
	Kernel driver in use: nvidia
	Kernel modules: nvidia, nouveau
Comment 2 Vedran Miletić 2009-10-26 11:02:26 EDT
Brian, this is not the same issue as original report. Please complain to NVIDIA about issues with their proprietary drivers since Fedora can't address them. If you used nouveau, that would be another situation.

Ravi, how about _complete_ Fedora 12 Beta (you can try with LiveCD)?
Comment 3 Brian Millett 2009-10-26 11:30:41 EDT
Ok, thought as much.

They fixed it in the 190.42 release.  I just thought that since the nouveau & nvidia drivers showed the same problem at the same time that there might be a related issue.  I do not believe in coincidences.
Comment 5 Vedran Miletić 2009-11-05 17:57:51 EST
This has been fixed in current post-Fedora 12 Beta rawhide packages.

Intel driver is actually working quite nice now.

Note You need to log in before you can comment on or make changes to this bug.