Bug 504973 - ISO image install from HD does not work without repo= boot parameter
ISO image install from HD does not work without repo= boot parameter
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Nalley
David Nalley
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 05:22 EDT by Bill Hammond
Modified: 2009-08-03 11:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 11:26:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Hammond 2009-06-10 05:22:33 EDT
Description of problem:
ISO image installation fails to find ISO file

Version-Release number of selected component (if applicable):
F11 release x86_64 DVD ISO

How reproducible:
Every time.


Steps to Reproduce:
1. Leave the DVD ISO file on the F10 /home or / partitions, boot the F11 DVD.
2. Installer fails to find ISO file without "repo=hd:sdxx:/path" boot parameter.
3. Boot with "repo=..." and the installer can find the file.
  
Actual results:
Installer begins network install.

Expected results:
Find the ISO automatically or ask for the location.

Additional info:
Seems to be similar to bug 491781 - at least the same solution makes the installer work.
Comment 1 Chris Lumens 2009-06-10 11:57:36 EDT
This is operating as expected.  If you boot with the DVD/boot.iso/whatever, anaconda defaults to using the mirrorlist provided by the fedora.repo file.  If you want to use your own custom method, you need to:  (1) pass repo=, or (2) pass askmethod, or (3) pxeboot.
Comment 2 Bill Hammond 2009-06-10 15:32:44 EDT
Then the install guide should be updated. There is no indication that params need to be passed for a HD ISO install, and the DVD/CD boot, boot.iso and direct kernel/initrd booting do not offer the option.
Comment 3 Ruediger Landmann 2009-08-03 11:26:48 EDT
Thanks Bill. 

Selecting an installation method is covered in Section 7.4 of the Installation Guide[1], which continues on to describe the various methods (DVD/CD, Hard Drive, Network, NFS) in sections 7.5 through 7.8.

That said, I've included specific mention of the required boot option in each of these sections, to avoid any confusion in the future.

Many thanks for pointing this out. The changes will become visible the next time that we republish the guide.

Cheers,
Ruediger

[1] http://docs.fedoraproject.org/install-guide/f11/en-US/html/s1-installmethod.html

Note You need to log in before you can comment on or make changes to this bug.