Bug 50499 - Stale postmaster.pid file blocks startup
Summary: Stale postmaster.pid file blocks startup
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-31 18:27 UTC by Jos Vos
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 22:24:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2001-07-31 18:27:48 UTC
When (e.g, after a system crash) a stale /var/lib/pgsql/data/postmaster.pid
file exists, the "postgresql start" init fails.  Also, and even worse, a
"postgresql stop" init also fails, after a very long delay, probably
because it tries to stop a non-existing process.

After removing the pid file, everything works fine.

Suggestion: maybe the init script can check whether the pid file is stale
or not, and remove it if it is a stale file, so that the standard
postgresql start/stop will work afterwards.

Comment 1 Glen Foster 2001-07-31 19:18:39 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Trond Eivind Glomsrxd 2001-08-06 22:24:16 UTC
Fixed in postgresql-7.1.2-7



Note You need to log in before you can comment on or make changes to this bug.