Bug 504991 - "Upgrade root not found" when preupgrading Fedora 8 -> Fedora 11
"Upgrade root not found" when preupgrading Fedora 8 -> Fedora 11
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 06:29 EDT by Juhani Jaakola
Modified: 2014-01-21 18:09 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (30.81 KB, text/plain)
2009-06-10 06:39 EDT, Juhani Jaakola
no flags Details
program.log (13.63 KB, application/octet-stream)
2009-06-10 06:40 EDT, Juhani Jaakola
no flags Details
storage.log (29.55 KB, text/plain)
2009-06-10 06:40 EDT, Juhani Jaakola
no flags Details

  None (edit)
Description Juhani Jaakola 2009-06-10 06:29:12 EDT
Description of problem:

I installed yesterday evening the latest preupgrade for Fedora 8 and after rebooting (and loading install.img from Internet because my /boot was too small for it) I got the error "Upgrade root not found"

Steps to Reproduce:
1. Install preupgrade in Fedora 8
2. preupgrade
3. reboot
  
Actual results:
Error "Upgrade root not found"

Expected results:
Upgrade to Fedora 11

Additional info:
Here are output from different virtual consoles during the bug with Fedora 8 preupgrade:

Ctrl+Alt+F3:
WARNING : Step complete does not exist
INFO : moving (1) to step findrootparts
INFO: Set SELinux context for mountpoint /mnt/sysiamge to None
INFO: Set SELinux context for newly mounted filesystem root at /mnt/sysimage to system_u:object_r:mnt_t:s0
[similar SELinux messages deleted]
WARNING : Step complete does not exist
INFO : moving (1) to step upgrademount

Ctrl+Alt+F4:
...
<6>EXT3-fs: mounted filesystem with ordered data mode.
<7>SELinux: initialized (dev sda9, type ext3), uses xattr.
<4>CE: hpet increasing min_delta_ns to 15000 nsec

I had disabled SElinux in Fedora 8.
Comment 1 Juhani Jaakola 2009-06-10 06:39:35 EDT
Created attachment 347194 [details]
anaconda.log
Comment 2 Juhani Jaakola 2009-06-10 06:40:20 EDT
Created attachment 347195 [details]
program.log
Comment 3 Juhani Jaakola 2009-06-10 06:40:50 EDT
Created attachment 347196 [details]
storage.log
Comment 4 Andy Lindeberg 2009-06-10 10:13:34 EDT
Anaconda explicitly does not support upgrading from more than two versions ago, and had you run an upgrade within anaconda, we would not have allowed you to continue.

If preupgrade is allowing you to try to upgrade from 8 to 11, that's a bug in preupgrade, not in anaconda. Reassigning.
Comment 5 daryl 2009-06-23 17:28:32 EDT
I dont think this is related to upgrading fedora 8 ->11(although the wiki claims this is possible)

I have the same exact issue using preupgrade from FC10 -> FC11 with the exact same error messages.
Comment 6 John Stracke 2009-07-27 10:55:05 EDT
(In reply to comment #5)

> I have the same exact issue using preupgrade from FC10 -> FC11 with the exact
> same error messages.  

So do I.
Comment 7 Matthew 2009-10-08 02:39:54 EDT
Maybe there's a solution. Try to upgrade your system iteratively but directly using preupgrade somehow.

1. FC8 -> FC10
2. FC10 -> FC11

It works.
Comment 8 Brian 2009-10-19 19:35:12 EDT
I'm doing a completely default preupgrade from Fedora 8 to Fedora 11, and consistently getting this error.  Fresh install of Fedora 8, nothing special on the partitioning.  The only thing I changed from the default is to remove the default 2gb swap and add 2x4gb swap partitions.  No dual-booting, nothing special.

I built the Fedora 8 system today, completely updated it via yum, installed preupgrade.  I then run preupgrade-cli or preupgrade (have messed with both) and do the reboot.  When I reboot it tells me the upgrade root was not found.

The clearpart --none workaround did nothing.

According to this:

http://fedoraproject.org/wiki/PreUpgrade

It seems like this "should" work.

----

The above comment about going only 2 steps isn't really a "solution".  The purpose of preupgrade is to: "PreUpgrade provides an upgrade directly to the latest version of Fedora. It is not necessary to upgrade to intermediate versions."

I'm trying to use preupgrade to skip iterative steps.  I have to upgrade 85 hosts.  If I wanted to do iterative upgrades, I'd use yum, it's far more convenient for upgrading systems remotely.
Comment 9 Bug Zapper 2010-04-27 10:43:29 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Scott Williams 2010-05-08 17:35:57 EDT
I would like to note that the way Fedora handles dev roots in grub has changed since f8. It used to go by device name such as /dev/sda2, but there was a change to using the UUID instead. Try running /sbin/blkid to get the UUID for the partitions and see if that helps with this error.
Comment 11 Bug Zapper 2010-06-28 08:51:31 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.