This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5050 - Not recognizing PCMCIA NIC on network install
Not recognizing PCMCIA NIC on network install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-10 13:56 EDT by raph
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 08:12:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description raph 1999-09-10 13:56:52 EDT
I'm trying to install RH 6.0 on a Thinkpad 560 with a 3c589
NIC. So far, I haven't been able to get it to recognize the
ethernet adapter.

I have a completely different set of symptoms with the
original boot disk and the updated ones (using the 19990909
update).

With the original boot disk, the driver for the network card
seems to be loaded, but apparently never configured. At no
time am I able to ping the card.

Here is the detailed sequence.

1. Boot from original RH 6.0 bootnet.img disk, selecting
"expert".

2. Insert original RH 6.0 pcmcia.img disk upon request.

3. The card is enabled (the green link detected light comes
on). However, this log message appears in the Alt-F4 log:

<30>Sep 10 12:40:53 cardmgr[13]: + ./network:
/etc/sysconfig/network-scripts/ifup: not found

4. I select "NFS image". I select "Static IP address"

5. I enter the ip address, and enter the other computer's ip
forboth gateway and nameserver (I will be using numeric ip
throughout).

6. At the screen "Determining host name and domain..." the
link light on the NIC goes dark. Running tcpdump on the
other computer, at no time is there any network activity. I
get "neighbor table overflow" and "device lo entered/left
promiscuous mode" messages in the Alt-F4 log.

7. Continuing anyway with "Configure Network" and "NFS
Setup", after entering NFS, the install simply hangs.

With the 19990909 bootnet.img, I have the following
symptoms:

1. Boot from 19990909 bootnet.img, using "expert".

2a. If I answer "yes" to pcmcia, it requests a pcmcia
floppy. There is no pcmcia.img present in the errata, so I
try the old one. It loads it, but I get the Alt-F4 message:
cardmgr: no pcmcia driver in /proc/devices. The link light
never comes on. If I proceed with "NFS install" (and "force
supplemental disk") I am presented with a menu of net
drivers that does not include 3c589 (it appears to be a
non-pcmcia list).

2b. Answering "no" to pcmcia gives me the same set of nic
drivers. Even though I selected "force supplemental disk",
it does not prompt me for one.

There is no (3), as I can't get pas the "load module" screen
for selecting a NIC.

Looking through this bugzilla, it seems likely that if I
could load the modules from the supplemental disk, I'd be
able to install. However, at no time before the "load
module" stage am I prompted to insert the supplemental disk.

This _feels_ like operator error, although I really can't
see anything I'm doing wrong. At absolute best, the
documentation that comes with the updated bootdisks is
totally inadequate, as it fails to mention the lack of the
pcmcia disk.

Thanks in advance!
Comment 1 raph 1999-09-11 00:54:59 EDT
I tried putting the laptop on the Internet and doing an FTP install
from ftp.redhat.com, using the original 6.0 boot images, and it's
working. Thus, it's likely that the problems I was having with the
original boot disks had more to do with my local Ethernet than with
RH. Perhaps I simply needed to run a nameserver.

In any case, the issues with the updated boot disk, particularly the
documentation of the pcmcia changes, would seem to remain.
Comment 2 vlmoran 1999-09-16 16:02:59 EDT
Actually, I think you have found a bug.
When the new boot images were made, a different kernel version was
used.  However no new pcmcia package was prepared.  Since the version
of the kernel is closely tied to the modules it makes sense that the
module is not loading.

according to the web site for pcmcia an error of "cardmgr: no pcmcia
driver in /proc/devices" means that there is a problem trying to load
the pcmcia module.

The only reason that you did not get that error is that you used the
older disks with matching versions.  Why your problems disappeared I
don't understand, but I am stuck right now with the module loading
problem.

I think the right solution is to take a close look at the module and
kernel versions and make sure that the new boot images have the
correct modules on them.  If not RH should put out an pcmcia image
specifically for use with the new boot disks.

Victor Moran.
Comment 3 Jay Turner 2000-02-08 08:11:59 EST
We have implemented tighter standards on releasing update disks for errata.  In
addition, we now have a consolidated pcmcia boot disk, so there is no longer any
need for a boot disk and the pcmcia disk in order to perform an installation.

Note You need to log in before you can comment on or make changes to this bug.