Bug 505001 - Gnumeric build badly needs upstream fix for GTK behavior change
Gnumeric build badly needs upstream fix for GTK behavior change
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 06:38 EDT by Luke Hutchison
Modified: 2009-11-11 19:56 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.6-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 19:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Hutchison 2009-06-10 06:38:36 EDT
A couple of changes were made to gtk 2.14 that caused serious usability problems with Gnumeric.

http://bugzilla.gnome.org/show_bug.cgi?id=580930
http://bugzilla.gnome.org/show_bug.cgi?id=566652

These problems have persisted through at least the last two Fedora releases (10 and 11).  They make several operations in Gnumeric unusable.

Please can a newer build of Gnumeric be picked up (either a patched version of 1.8.4, or the development version 1.9.8) and pushed out as an update to F11.  It would be a shame if these bugs had to persist throughout the lifetime of F11.  Thank you!
Comment 1 Luke Hutchison 2009-10-18 23:20:12 EDT
This is still a problem in the latest Fedora 12 gnumeric RPMs.  Dragging or resizing a chart in Gnumeric is really problematic, and several spinner widgets don't work correctly.  Can this please be fixed before the F12 release?
Comment 2 Robert Scheck 2009-10-20 18:31:34 EDT
I'm not the gnumeric package maintainer, but I'm fixing now, what the package
maintainer unfortunately has not done so far...
Comment 3 Luke Hutchison 2009-10-20 18:42:09 EDT
Thank you Robert!  You might even want to check on including the 1.9 branch of gnumeric in Fedora if that is possible, it has a lot of other bug fixes and as far as I know it is pretty solid despite not being labeled a stable release.  (It's certainly better than the current Fedora gnumeric-1.8.4 "stable" package :) )

Much appreciated.
Comment 4 Robert Scheck 2009-10-20 18:45:23 EDT
I've applied all missing fixes from the gnumeric 1.8 stable branch:

F-11: http://koji.fedoraproject.org/koji/buildinfo?buildID=137574
F-12: http://koji.fedoraproject.org/koji/buildinfo?buildID=137573
devel: http://koji.fedoraproject.org/koji/buildinfo?buildID=137572
Comment 5 Fedora Update System 2009-10-20 18:50:03 EDT
gnumeric-1.8.4-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-5.fc11
Comment 6 Robert Scheck 2009-10-20 18:53:39 EDT
For gnumeric-1.8.4-5.fc12 see: https://fedorahosted.org/rel-eng/ticket/2601
Comment 7 Luke Hutchison 2009-10-20 19:02:30 EDT
I just tested these packages, and the graph dragging/resizing problem is not fixed, I think the goffice package probably needs to be updated too?
Comment 8 Robert Scheck 2009-10-20 19:12:18 EDT
Looks like the other issue is goffice, but that's not the gnumeric package,
so please open a bug report against the goffice component. I will now close
this bug report as the gnumeric part is done.
Comment 9 Fedora Update System 2009-10-20 19:14:34 EDT
gnumeric-1.8.4-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnumeric-1.8.4-5.fc10
Comment 10 Fedora Update System 2009-10-21 06:06:24 EDT
goffice-0.6.6-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/goffice-0.6.6-4.fc10
Comment 11 Fedora Update System 2009-11-11 19:51:33 EST
gnumeric-1.8.4-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-11-11 19:52:58 EST
gnumeric-1.8.4-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-11-11 19:54:36 EST
gnome-chemistry-utils-0.10.8-1.fc10.1, goffice-0.6.6-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-11-11 19:56:08 EST
goffice-0.6.6-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.