Bug 505012 - Monitoring, selinux denial for snmp probe , "TSDBLocalQueue."
Monitoring, selinux denial for snmp probe , "TSDBLocalQueue."
Status: CLOSED DUPLICATE of bug 498611
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
https://grandprix.rhndev.redhat.com/r...
:
Depends On: 501546
Blocks: 457079 463877
  Show dependency treegraph
 
Reported: 2009-06-10 07:30 EDT by wes hayutin
Modified: 2009-08-20 18:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 501546
Environment:
Last Closed: 2009-06-11 04:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-10 07:30:00 EDT
+++ This bug was initially created as a clone of Bug #501546 +++

Description of problem:
sat530 6/5 build rhel 530


type=AVC msg=audit(1244481688.823:2940): avc:  denied  { getattr } for  pid=11605 comm="gogo.pl" path="/var/lib/nocpulse/commands/heartbeat" dev=dm-0 ino=1578391 scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=root:object_r:var_lib_t:s0 tclass=file

recreate:
1. setup monitoring 
2. setup client w/ monitoring
3. create snmp probe

w/ selinux on get the above denial
Comment 1 Miroslav Suchý 2009-06-11 04:33:24 EDT
This is the same problem as described in https://bugzilla.redhat.com/show_bug.cgi?id=498611#c5

*** This bug has been marked as a duplicate of bug 498611 ***
Comment 2 John Sefler 2009-08-20 18:16:09 EDT
re-ran the recreate steps on webqa build (Satellite-5.3.0-RHEL5-re20090817.0)

did not encounter the same denial listed in the problem description.

did encounter this denial in /var/log/audit/audit.log
type=AVC msg=audit(1250805561.953:964): avc:  denied  { search } for  pid=31885 comm="httpd" name="" dev=0:19 ino=25871573 scontext=root:system_r:httpd_t:s0 tcontext=system_u:object_r:nfs_t:s0 tclass=dir

However, the snmp probe monitoring in the satellite GUI was a success.
If there is still a problem here, we'll let the duplicate defect 498611 catch it.

adding ClosedValid to the QA Whiteboard

Note You need to log in before you can comment on or make changes to this bug.