Bug 505039 - Preupgrade fails during metadata generation (F10->F11)
Preupgrade fails during metadata generation (F10->F11)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 09:32 EDT by Tarjei Knapstad
Modified: 2014-01-21 18:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 09:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tarjei Knapstad 2009-06-10 09:32:07 EDT
Description of problem:
Just started a preupgrade from F10 to F11 and everything went fine until an exception was raised during metadata generation.

Version-Release number of selected component (if applicable):
preupgrade-1.1.0-1.fc10.noarch

How reproducible:
Allways

Steps to Reproduce:
1. Start preupgrade on F10 installation
2. Start upgrade process from F10 to F11
3. Crashes during metadata generation
  
Actual results:
Exception raised during metadata generation

Expected results:
Preupgrade completes successfully.

Additional info:
Backtrace:

Generating metadata for preupgrade repo
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 238, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 545, in main_preupgrade
    callback=MDGenCallback(pbar=self.progress))
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 651, in generate_repo
    misc.generate_repodata(dir,comps,callback)
  File "/usr/lib/python2.5/site-packages/preupgrade/misc.py", line 131, in generate_repodata
    generate_repodata(dir, comps, callback)
  File "/usr/lib/python2.5/site-packages/preupgrade/misc.py", line 147, in generate_repodata_f9
    mdgen.doPkgMetadata()
  File "/usr/lib/python2.5/site-packages/createrepo/__init__.py", line 332, in doPkgMetadata
    self.writeMetadataDocs(packages)
  File "/usr/lib/python2.5/site-packages/createrepo/__init__.py", line 472, in writeMetadataDocs
    self.primaryfile.write(po.xml_dump_primary_metadata())
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 1014, in xml_dump_primary_metadata
    msg += misc.to_unicode(self._dump_base_items())
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 847, in _dump_base_items
    (csum_type, csum, csumid) = self.checksums[0]
IndexError: list index out of range
Comment 1 seth vidal 2009-06-10 09:37:40 EDT
Install createrepo 0.9.7 from F10-updates/updates-testing. You have yum 3.2.23 installed, I suspect, which is why there is an issue.
Comment 2 Tarjei Knapstad 2009-06-10 09:59:34 EDT
Suspicion confirmed Seth, looks like I've managed to upgrade to yum 3.2.23 from updates-testing at some point... Updated createrepo from updates-testing as well and everything went fine after that. The yum update also caused this which flew by me the first time around, so I think the best solution would be to just downgrade from the updates-testing stuff:

yum-3.2.23-3.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package yum-3.2.23-3.fc10.noarch (installed)

Sorry about the noise.

Note You need to log in before you can comment on or make changes to this bug.