Bug 505050 - Wrong NULL check
Wrong NULL check
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mdsplib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 09:58 EDT by Curious
Modified: 2009-06-15 21:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.11-9.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:27:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curious 2009-06-10 09:58:13 EDT
Description of problem: Using the library may lead to Segmentation fault.


How reproducible: At any use of the library with a lot of lightning information


Steps to Reproduce:
1. download a metar file, tgftp.nws.noaa.gov anonymous
2. Use the dcdMETAR function on a high number of statement (using one by one may not lead to this problem.
  
Actual results: May cause a Segmentation fault => software crash.


Additional info: The problem is due to a wrong NULL verification.

Line : 1990 - 1993 : 
      if( *string == NULL )
         return FALSE;
 
      (--string);

Should be : 
      (--string);

      if( *string == NULL )
         return FALSE;
Comment 1 Matthias Saou 2009-06-11 06:09:55 EDT
Nice catch. I'm rebuilding the devel package right now, then I'll also backport the change, as well as another recent fix by Karsten Hopp, to all current branches.
Comment 2 Fedora Update System 2009-06-11 07:14:57 EDT
mdsplib-0.11-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/mdsplib-0.11-9.fc10
Comment 3 Fedora Update System 2009-06-11 07:15:01 EDT
mdsplib-0.11-9.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/mdsplib-0.11-9.fc9
Comment 4 Fedora Update System 2009-06-11 07:15:07 EDT
mdsplib-0.11-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mdsplib-0.11-9.fc11
Comment 5 Fedora Update System 2009-06-15 21:27:02 EDT
mdsplib-0.11-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-06-15 21:40:35 EDT
mdsplib-0.11-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-06-15 21:55:42 EDT
mdsplib-0.11-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.