Bug 505060 - Incorrect passwd file created
Incorrect passwd file created
Status: CLOSED DUPLICATE of bug 500123
Product: Fedora
Classification: Fedora
Component: gnome-user-share (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 10:47 EDT by Torsten Rausche
Modified: 2009-06-29 05:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 05:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 586755 None None None Never

  None (edit)
Description Torsten Rausche 2009-06-10 10:47:58 EDT
Description of problem:
Gnome-user-share creates an incorrect passwd file. Therefore you can not access the shared directory over network if full password protection is enabled. This may be related to localization (see below). I am using LANG=de_DE.UTF-8.

Version-Release number of selected component (if applicable):
gnome-user-share-2.26.0-2.fc11.x86_64
httpd-2.2.11-8.x86_64

Steps to Reproduce:
(0. Switch to a non-english locale)
1. Enable sharing over network and set password protection to 'always'
2. Look up the used port, e.g. using 'ps x | grep httpd'
3. Try to connect, e.g. using 'cadaver dav://localhost:PORT/', and try to login with username 'guest' and the chosen password
  
Actual results:
[...]
Authentication required for Please log in as the user guest on server `localhost':
Username: guest
Password: 
[...]
Could not authenticate to server: rejected Digest challenge

Expected results:
Access to the shared directory

Additional info:
The log tells me:
[error] [client ::1] Digest: user `guest' in realm `Please log in as the user guest' not found: /

Content of ~/.config/user-share/passwd:
guest:Bitte melden Sie sich als Gastbenutzer an:46f7b560a0cd0b8d96966ea30eb8b275

==> This can not work while the realm does not match. A localization issue?

If I recreate the passwd file using using the htdigest command
$ htdigest -c /home/rat/.config/user-share/passwd \
  'Please log in as the user guest' guest
the content of ~/.config/user-share/passwd is:
guest:Please log in as the user guest:b5c3b4ba5f1b1b50baf6852eb150c29c

==> As you can see, the realm _and_ the password parts differ from the original entry.

With the manually created passwd file I can login as expected.
Comment 1 Bastien Nocera 2009-06-29 05:52:39 EDT
Fixed upstream.
Comment 2 Bastien Nocera 2009-06-29 05:53:33 EDT

*** This bug has been marked as a duplicate of bug 500123 ***

Note You need to log in before you can comment on or make changes to this bug.