Bug 505068 - Compaq cpqarray is not supported
Compaq cpqarray is not supported
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-06-10 11:06 EDT by k960154
Modified: 2009-06-15 10:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-15 10:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Attached traceback automatically from anaconda. (63.98 KB, text/plain)
2009-06-10 11:06 EDT, k960154
no flags Details

  None (edit)
Description k960154 2009-06-10 11:06:38 EDT
The following was filed automatically by anaconda:
anaconda exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/livecd.py", line 393, in doBackendSetup
    if slash.size < ossize:
  File "/usr/lib/anaconda/backend.py", line 271, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
AttributeError: 'NoneType' object has no attribute 'size'
Comment 1 k960154 2009-06-10 11:06:44 EDT
Created attachment 347241 [details]
Attached traceback automatically from anaconda.
Comment 2 k960154 2009-06-10 11:24:09 EDT
Hi, I've been trying to install fedora 11 on a Compaq Proliant ML370 G1 since the beta release.https://bugzilla.redhat.com/token.cgi?t=hy7M820Gsj&a=request_new_account

I keep getting the same error during installation whether I use the live CD or the DVD to install.  The system is a twin pentium 3 866MHz system with 4GB ram (was 1GB when i started trying to install).  The system has a compaq smart-2/p scsi RAID card and I have tried different raid configurations to get this  to work.  Currently the main raid set is 2X 9GB ultra 3 scsi in a raid 0 configuration.

The drivers for the raid card (cpqarray) do load as I can drop to a shell during installation and create /edit the partitions on the raid set (/dev/ida/c0d0) without any problems.

I have tried earlier releases of fedora to see if i get the same problem but the only one that has worked perfectly so far is fedora core-4.  However There is no online upgrade path from this anymore and I wanted to try btrfs for my root and on a secondary raid set for storage.

I have tried using the -r option to liveinst after creating a filesystem and mounting it on /mnt/sysimage to specify to install there but I get the same error.

I have also tried manually installing installing fedora 11 by installing on a vmware virtual machine and creating a tarball of the complete filesystem.

Then installing grub on the /boot partition on the server and unpacking the tarball on the hard disk.  After changing the guids in /etc/grub.conf the boot process hangs after detecting the mouse (I think this is the just before it switches to the new root fileystem but cannot be sure).

Any advice would be appreciated.
Comment 3 k960154 2009-06-10 21:16:44 EDT
Hi Chris,
so just to clarify.  Cpqarray is a driver shipped in the stock installation kernel for fedora 11.  Anaconda does not support all the drivers in the standard kernel and there isn't a switch to say " I've already mounted the filesystems I want under /mnt/sysimage.  Just continue the installation!"

If that is the case, what is the -r switch to anaconda/liveinst for?

Don't mean to sound funny but this is just confusing...

Is there a manual way to do the steps that anaconda/liveinst performs?
Comment 4 Chris Lumens 2009-06-11 09:35:40 EDT
Just because there's a driver doesn't mean it's really supported.  No one here has even seen one of these devices, let alone has one.  I talked to multiple kernel guys yesterday and they were surprised the support is even still being included.  They don't have access to the hardware either.  So no, there's no guarantee that something built into the kernel is really fully supported throughout the distribution.

-r isn't going to help you, because anaconda still needs to detect your hardware for various reasons.  That's where the problem is coming from - the hardware detection, not just the filesystem mounting.
Comment 5 k960154 2009-06-11 09:45:50 EDT
Ok, thanks for clearing that up.  I'll do some more research and see if I can do a manual install.  If I can I'll post the results somewhere so other people in the same situation ( driver in kernel but not directly supported anymore) might find some help.

Thanks again.

Note You need to log in before you can comment on or make changes to this bug.