Bug 505076 - unable to install with default ati driver with radeon 9200 card
unable to install with default ati driver with radeon 9200 card
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 11:32 EDT by Tom Horsley
Modified: 2009-11-29 00:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-29 00:34:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2009-06-10 11:32:12 EDT
Description of problem:

I tried to install on a system which has this graphics card:

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)

In 5 attempts, I got 5 random failures. System just stopped installing
(but mouse kept moving), system froze up (no mouse movement), dialog
boxes popped up with black contents and system freeze, etc.

On my 6th attempt I added the "vesa" option to the installer boot
options and everything worked fine.

This leads me to believe the problem is with the radeon driver :-).

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-14.fc11.i586

How reproducible:
different random failures each time, but it always fails before getting very
far into the install.

Steps to Reproduce:
1.try to install fedora 11
2.
3.
  
Actual results:
seemingly random failures

Expected results:
installed system

Additional info:

A different system I have with an ati card installed with no problems.
It has:

01:00.0 VGA compatible controller: ATI Technologies Inc RV610 video device [Radeon HD 2400 PRO]

So not all ati cards barf in fedora 11, just some of them.
Comment 1 Matěj Cepl 2009-06-16 09:48:53 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) from an unsuccesful attempt with default settings to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Tom Horsley 2009-06-16 10:06:59 EDT
I'm afraid I'm unlikely to get any of that any time soon. Since I got the
machine working with vesa, it has now gone into production use and the
original files are long gone, having been wiped out by the install that
worked.

If I can get to the machine again someday, I'll try the install again and
see if I can collect the files, but it isn't likely to be soon.
Comment 3 Matěj Cepl 2009-06-17 06:21:42 EDT
OK, I will give you month, and if I won't get any interesting data by then, I will close this INSUFFICIENT_DATA.
Comment 4 Matěj Cepl 2009-11-05 13:31:08 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 5 Chris Campbell 2009-11-29 00:34:53 EST
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.