Bug 505098 - no repomd.xml file during install
no repomd.xml file during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:76f1673c3d05103e0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 12:14 EDT by Roger Mach
Modified: 2014-01-21 18:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 10:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (210.54 KB, text/plain)
2009-06-10 12:14 EDT, Roger Mach
no flags Details
anaconda execption report from fedora 12 alpha installation (97.60 KB, text/plain)
2009-09-03 17:59 EDT, Roger Mach
no flags Details

  None (edit)
Description Roger Mach 2009-06-10 12:14:37 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/repoMDObject.py", line 84, in __init__
    infile = open(srcfile, 'rt')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 958, in _parseRepoXML
    return repoMDObject.RepoMD(self.id, local)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1158, in _commonLoadRepoXML
    self._repoXML = self._parseRepoXML(result)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1303, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1319, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1329, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1337, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1174, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 488, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 464, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1082, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1109, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1083, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/yuminstall.py", line 1037, in doBackendSetup
    self.doSackSetup(anaconda)
  File "/usr/lib/anaconda/backend.py", line 271, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/var/cache/yum/fedora/repomd.xml'
Comment 1 Roger Mach 2009-06-10 12:14:44 EDT
Created attachment 347252 [details]
Attached traceback automatically from anaconda.
Comment 2 Roger Mach 2009-06-10 13:39:00 EDT
I was mistaken when I originally described this error as being seen during a uefi installation.  This was a legacy mode installation from DVD to a disk with a GPT label, which is probably an unusual combination but as far as I know should be supported.
Comment 3 Roger Mach 2009-06-11 19:23:51 EDT
This problem has now also occurred during a uefi installation to a disk with a GPT disklabel.
Comment 4 seth vidal 2009-09-03 11:33:51 EDT
I have no idea at all. Can you make this happen if you use rawhide/f12alpha?
Comment 5 Roger Mach 2009-09-03 17:59:09 EDT
Created attachment 359737 [details]
anaconda execption report from fedora 12 alpha installation

As requested, I tried installing Fedora 12 Alpha on the same machine where I saw the original issue.  I did not get the same error but did hit a different anaconda failure as detailed in the attached exception report.
Comment 6 seth vidal 2009-09-04 10:18:07 EDT
reassigning this error over to anaconda.
Comment 7 Chris Lumens 2009-09-04 10:30:58 EDT
Since the original issue appears to be fixed in F12 Alpha, I'm going to close this bug out.  We have plenty of reports of the second issue described in comment #5, which I believe are assigned to python-pyblock.

Note You need to log in before you can comment on or make changes to this bug.