Bug 505120 - (LiveCDSinglePart) Can't install fc11 with all filesystems in a single partition
Can't install fc11 with all filesystems in a single partition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
have the dvd images been released yet...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 14:03 EDT by bruce damkoehler
Modified: 2009-06-10 14:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 14:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bruce damkoehler 2009-06-10 14:03:07 EDT
Description of problem:I tried to install the fc11 kde live cd in a single partition over an existing suse installation, using /dev/sda8 as / with its default of ext4. I got a message stating that "bootable partitions cannot be on an ext4 filesystem". I changed it to ext3 and tried it again. This time I got a message stating "Your / partition does not match the live image that you are installing from. It must be formatted as ext4". It appears that you cannot install fc11 with all its filesystem in a single partition. Is that true? It is the way that I have always done my installations (regardless of distribution). 


Version-Release number of selected component (if applicable):


How reproducible:
I tried it twice while I was booted. It was repeatable then. I did not try booting again, but I assume that it will happen every time. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-06-10 14:05:59 EDT
You cannot currently install from the livecd to a single partition, correct.  This is due to two reasons:

(1) grub does not currently support booting from ext4, only ext3.

(2) The livecd installer simply copies over the contents of the CD to the filesystem.  Since the filesystem on the CD is ext4, it requires that your root partition also be ext4.
Comment 2 Jeremy Katz 2009-06-10 14:26:14 EDT
So if you want to install onto a single partition (or use a non-ext4 / for any other reason), then you must install from either the network install ISO (boot.iso) or from the DVD.

Note You need to log in before you can comment on or make changes to this bug.