Bug 505126 - Installing F11x64 with Virtual Machine Manager to physical drive partitions w/custom layout
Installing F11x64 with Virtual Machine Manager to physical drive partitions w...
Status: CLOSED DUPLICATE of bug 517833
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d70d4f6f759857605...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 14:20 EDT by Randy Cole
Modified: 2010-06-08 03:34 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 08:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (158.08 KB, text/plain)
2009-06-10 14:20 EDT, Randy Cole
no flags Details
Attached traceback automatically from anaconda. (146.16 KB, text/plain)
2009-06-14 13:18 EDT, howe.howie
no flags Details
Attached traceback automatically from anaconda. (450.93 KB, text/plain)
2009-06-16 06:18 EDT, Mark Knoop
no flags Details
Attached traceback automatically from anaconda. (435.38 KB, text/plain)
2009-06-25 01:54 EDT, Pavel Morozov
no flags Details
Attached traceback automatically from anaconda. (325.58 KB, text/plain)
2009-07-02 10:13 EDT, George Beshers
no flags Details
Attached traceback automatically from anaconda. (512.83 KB, text/plain)
2009-07-23 14:02 EDT, bache.richard
no flags Details
Attached traceback automatically from anaconda. (920.51 KB, text/plain)
2009-09-25 15:50 EDT, Robert Townley
no flags Details
Attached traceback automatically from anaconda. (426.65 KB, text/plain)
2009-10-02 19:59 EDT, Devrim GÜNDÜZ
no flags Details
Attached traceback automatically from anaconda. (483.79 KB, text/plain)
2009-10-16 17:57 EDT, UnkName
no flags Details
Attached traceback automatically from anaconda. (272.38 KB, text/plain)
2009-11-21 12:58 EST, Zenith88
no flags Details
Attached traceback automatically from anaconda. (253.82 KB, text/plain)
2010-04-21 15:42 EDT, xprezons
no flags Details
Attached traceback automatically from anaconda. (626.98 KB, text/plain)
2010-06-08 03:34 EDT, sem
no flags Details

  None (edit)
Description Randy Cole 2009-06-10 14:20:46 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/swap.py", line 86, in swapon
    raise SwapError("swapon failed for '%s'" % device)
  File "/usr/lib/anaconda/storage/formats/swap.py", line 119, in setup
    swap.swapon(self.device, priority=self.priority)
  File "/usr/lib/anaconda/storage/__init__.py", line 1581, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/packages.py", line 196, in turnOnFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
SwapError: swapon failed for '/dev/sda6'
Comment 1 Randy Cole 2009-06-10 14:20:53 EDT
Created attachment 347275 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-06-10 14:29:13 EDT
Does /dev/sda6 even exist?
Comment 3 howe.howie 2009-06-14 13:18:01 EDT
Created attachment 347838 [details]
Attached traceback automatically from anaconda.
Comment 4 Mark Knoop 2009-06-16 06:18:34 EDT
Created attachment 348076 [details]
Attached traceback automatically from anaconda.
Comment 5 Randy Cole 2009-06-18 15:55:10 EDT
(In reply to comment #2)
> Does /dev/sda6 even exist?  

Yes, /dev/sda6 did exist, marked as swap space, *BUT WAS NOT VALIDLY FORMATTED*.  The install proceeds to use it and crashes.

The workaround was to restart the install, go back into custom formatting, and check the box to allow Anaconda to format the partition.

I guess the correct fix is to have Anaconda check that the swapspace is formatted before it tries to use it, and not proceed until it is resolved.
Comment 6 Pavel Morozov 2009-06-25 01:54:26 EDT
Created attachment 349329 [details]
Attached traceback automatically from anaconda.
Comment 7 George Beshers 2009-07-02 10:13:48 EDT
Created attachment 350277 [details]
Attached traceback automatically from anaconda.
Comment 8 Chris Lumens 2009-07-09 16:18:08 EDT
Okay, just to make sure I've got this completely straight.

You had a swap partition somewhere on disk.  Randy, yours was sda6.  Other people are having different things.  In the custom partitioning layout, you did not specify that anaconda should format it.

Now here's the critical part I want to be sure of:  you also did not tell anaconda to mount or otherwise use the partition.  Correct?  So, anaconda just grabbed all swap partitions it could find and one of them happened to be invalid.
Comment 9 Randy Cole 2009-07-09 18:52:44 EDT
Chris, I believe I told Anaconda to use sda6 as swapspace, but not to format it.
Comment 10 bache.richard 2009-07-23 14:02:05 EDT
Created attachment 354901 [details]
Attached traceback automatically from anaconda.
Comment 11 Joel Andres Granados 2009-09-03 08:14:23 EDT

*** This bug has been marked as a duplicate of bug 517833 ***
Comment 12 Robert Townley 2009-09-25 15:50:20 EDT
Created attachment 362713 [details]
Attached traceback automatically from anaconda.
Comment 13 Devrim GÜNDÜZ 2009-10-02 19:59:47 EDT
Created attachment 363536 [details]
Attached traceback automatically from anaconda.
Comment 14 UnkName 2009-10-16 17:57:12 EDT
Created attachment 365097 [details]
Attached traceback automatically from anaconda.
Comment 15 Zenith88 2009-11-21 12:58:53 EST
Created attachment 372775 [details]
Attached traceback automatically from anaconda.
Comment 16 xprezons 2010-04-21 15:42:07 EDT
Created attachment 408156 [details]
Attached traceback automatically from anaconda.
Comment 17 sem 2010-06-08 03:34:34 EDT
Created attachment 422076 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.