This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505128 - preupgrade doesn't sync GPT on intel macs
preupgrade doesn't sync GPT on intel macs
Status: CLOSED DUPLICATE of bug 503149
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 14:23 EDT by Alexander Larsson
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 14:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2009-06-10 14:23:17 EDT
I used preupgrade to go from F10 to F11 on my Macbook pro (intel). Everything seemed to work, but after the final restart the "windows" icon wasn't visible in bootcamp.

Booting the live cd and running gptsync on /dev/sda fixed it.
Comment 1 Will Woods 2009-06-10 14:34:43 EDT
preupgrade doesn't touch the partition table, and it specifically directs anaconda *not* to reinstall the bootloader, by using 'bootloader --upgrade --location=none'. 

Is anaconda supposed to run gptsync? Maybe telling it not to install the bootloader causes it to forget to run gptsync?
Comment 2 Andy Lindeberg 2009-06-10 14:36:44 EDT

*** This bug has been marked as a duplicate of bug 503149 ***

Note You need to log in before you can comment on or make changes to this bug.