Bug 505129 - dejavu lgc serif condensed italic gets confused with condensed
dejavu lgc serif condensed italic gets confused with condensed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dejavu-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 14:37 EDT by Julian Sikorski
Modified: 2009-09-07 15:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 15:30:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2009-06-10 14:37:49 EDT
Description of problem:
There are some problems with DejaVu LGC Serif Condensed Italic font, which make it unavailable to gtk font selector and fc-list.

Version-Release number of selected component (if applicable):
fontconfig-2.6.0-3.fc10

How reproducible:
always

Steps to Reproduce:
1. Start gedit
2. Go to edit → preferences → fonts and colours
3. Uncheck system fonts usage, start font selector
4. Pick dejavu lgc serif
  
Actual results:
There are two “Condensed” entries in the styles box, but there is no condensed italic.

Expected results:
Condensed and Condensed Italic are both present once.

Additional info:
[jsikorski@snowball ~]$ rpm -ql dejavu-lgc-fonts | grep Serif
/usr/share/fonts/dejavu/DejaVuLGCSerif-Bold.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerif-BoldItalic.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerif-Italic.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerif.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerifCondensed-Bold.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerifCondensed-BoldItalic.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerifCondensed-Italic.ttf
/usr/share/fonts/dejavu/DejaVuLGCSerifCondensed.ttf
[jsikorski@snowball ~]$ fc-list | grep LGC | grep Serif
DejaVu LGC Serif:style=Italic
DejaVu LGC Serif,DejaVu LGC Serif Condensed:style=Condensed,Book
DejaVu LGC Serif,DejaVu LGC Serif Condensed:style=Condensed Bold Italic,Bold Italic
DejaVu LGC Serif:style=Bold
DejaVu LGC Serif:style=Book
DejaVu LGC Serif:style=Bold Italic
DejaVu LGC Serif,DejaVu LGC Serif Condensed:style=Condensed Bold,Bold

nim-nim found out the following:
[nim@arekh ~]$ fc-query /usr/share/fonts/dejavu/DejaVuSerifCondensed-Italic.ttf |grep style:
<nim-nim>  style: "Condensed"(s) "Book"(s)
<nim-nim> [nim@arekh ~]$ fc-query /usr/share/fonts/dejavu/DejaVuSansCondensed-Oblique.ttf |grep style
<nim-nim>  style: "Condensed Oblique"(s) "Oblique"(s)

He said that this could be some  “Oblique” vs “Italic” problem. Also, bug #466678 might be related, but I'm not sure about that.
Comment 1 Nicolas Mailhot 2009-06-10 15:08:17 EDT
It seems that while the name and OS/2 bits are correct and similar for both fonts, the TTF Style subfamily for DejaVuSerifCondensed-Italic is Book and not Italic (DejaVuSansCondensed-Oblique has Oblique there)

So it seems to be a font bug after all

Note You need to log in before you can comment on or make changes to this bug.