Bug 505132 - NOUVEAU:G72M:GeForce Go 7300 displays black vertical lines on Dell D620 laptop
NOUVEAU:G72M:GeForce Go 7300 displays black vertical lines on Dell D620 laptop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 14:59 EDT by Rik van Riel
Modified: 2010-03-31 07:00 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-31 07:00:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from kernel 2.6.29.5-191.fc11.i586 on D620 (41.78 KB, text/plain)
2009-07-07 20:53 EDT, ^mp3axe^
no flags Details
Xorg.0.log from Kernel 2.6.29.5-191.fc11.i586 on D620 (47.37 KB, text/plain)
2009-07-07 20:56 EDT, ^mp3axe^
no flags Details
dmesg output from kernel 2.6.29.5-191.fc11.i586 on D620 wtih drm,.debug-1 (71.62 KB, text/plain)
2009-07-07 21:28 EDT, ^mp3axe^
no flags Details

  None (edit)
Description Rik van Riel 2009-06-10 14:59:09 EDT
Description of problem:

When using the nouveau kernel driver (in the initrd) on the Dell D620 laptop, the screen has black vertical lines all over it.  In fact, it appears that every other pixel is black.

Not using the nouveau kernel driver (Adam was friendly enough to remove that from my initrd while we were trying to narrow things down) results in a properly working display again.

Even the text console seems to suffer from the black vertical lines.

Version-Release number of selected component (if applicable):

kernel-2.6.29.4-167.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11.x86_64

Hardware:

Dell D620 laptop, with
1440x900 display,
nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

Steps to Reproduce:
1. boot the system
2. type in whole-disk encryption password (at this point the screen is still good)
3. watch the subsequent screens come up with black lines
  
Additional info:

With the 'nv' and 'vesa' drivers in X, the screen has black lines but takes up the right size.  Using the 'nouveau' driver in X, together with the nouveau driver in the kernel, does not work at all.
Comment 1 Per Winkvist 2009-06-12 11:30:37 EDT
Problem occurs for me too with the same chipset
nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

When I start X I get blue/grey/white blooming with every other vertical line black. When I switched to a console it was blue with white text.
Comment 2 ^mp3axe^ 2009-07-07 20:53:23 EDT
Created attachment 350878 [details]
dmesg output from kernel 2.6.29.5-191.fc11.i586 on D620

dmesg output from kernel 2.6.29.5-191.fc11.i586
Comment 3 ^mp3axe^ 2009-07-07 20:56:38 EDT
Created attachment 350880 [details]
Xorg.0.log from Kernel 2.6.29.5-191.fc11.i586 on D620
Comment 4 ^mp3axe^ 2009-07-07 21:28:20 EDT
Created attachment 350882 [details]
dmesg output from kernel 2.6.29.5-191.fc11.i586 on D620 wtih drm,.debug-1

dmesg output from kernel 2.6.29.5-191.fc11.i586 on D620 wtih drm,.debug-1
Comment 5 ^mp3axe^ 2009-07-07 21:33:08 EDT
I have added drm.debug-1reulgrm default output demesgout, as wellas Xorg.0.log
Comment 6 Per Winkvist 2009-08-28 11:38:54 EDT
Problem happens with F12 Alpha 1 as well.
Comment 7 Per Winkvist 2009-08-28 11:45:36 EDT
Problem happens with F12 Alpha 1 as well.
Comment 8 Per Winkvist 2009-10-14 14:42:50 EDT
Problem happens with F12-Snap3-i686 as well.
Comment 9 Per Winkvist 2009-10-20 13:10:37 EDT
Problem happens with F12 Beta 1 as well.
Comment 10 Andy Campbell 2009-12-01 14:18:28 EST
Also in F12 final.
Comment 11 gurukiran venugopal 2010-01-17 02:26:49 EST
Same here, even with the latest update.
Comment 12 Pavel Rosenboim 2010-03-18 03:51:37 EDT
Sadly, F13 alpha is still unusable on Dell D620.
Comment 13 Ben Skeggs 2010-03-18 18:59:55 EDT
I've found a user who's been willing to go through the pain required to debug/fix this remotely with me recently, and fixes will soon make it upstream.  F12/F13 will both get the fixes once things have been tested properly.
Comment 14 Fedora Update System 2010-03-29 02:10:38 EDT
kernel-2.6.32.10-92.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.32.10-92.fc12
Comment 15 Fedora Update System 2010-03-29 22:21:41 EDT
kernel-2.6.32.10-92.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.32.10-92.fc12
Comment 16 Per Winkvist 2010-03-30 16:09:41 EDT
Works for me with Dell D620
Comment 17 Vedran Miletić 2010-03-31 07:00:56 EDT
Thank you for reporting back.

Note You need to log in before you can comment on or make changes to this bug.