Bug 505142 - Preupgrade results in i586 instead of i686
Preupgrade results in i586 instead of i686
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
i686 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 15:35 EDT by Andrey
Modified: 2014-01-21 18:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 09:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrey 2009-06-10 15:35:09 EDT
Description of problem:

When using preupgrade for moving from F10 to F11 my architecture switched from i686 to i586.

Version-Release number of selected component (if applicable):

Latest from F10 available.

How reproducible:

Just execute preupgrade.

Actual results:

Latest f10.i686 kernel and packages replaced by default i586 ones.


Expected results:

To have i686 kernel and packages.


Additional info:

http://www.smolts.org/show?uuid=pub_f6cf390b-d30c-43de-889e-2dc261726153

Initial smolt profile.
Comment 1 Andrey 2009-06-10 16:38:50 EDT
I have found some discussion with this specific message:

http://osdir.com/ml/fedora-test-list/2009-04/msg00343.html

If I understand it correctly from notice [3] in the very end of that message, my device will get i586 and that is not a mistake but some change in naming convention.

If it is true, I would expect some information in the Release notes. Right now I couldn`t find anything there.
Comment 2 Will Woods 2009-06-11 09:25:51 EDT
The first page of the Fedora 11 Release Notes (Section 1.4) suggests that you check the Common Bugs page. 

On that page, you'll find this:
http://fedoraproject.org/wiki/Common_F11_bugs#Can.27t_find_.i686_kernel

Hope that helps clear up any remaining confusion.
Comment 3 Andrey 2009-06-11 10:00:09 EDT
Thank you for quick answer. I still suggest having more clear information in release notes because this is feature not a bug and normally explanation is expected to be somewhere in Architecture part of RN.

Note You need to log in before you can comment on or make changes to this bug.