Bug 505178 - F11 GOLD - TypeError: value is of the wrong type for this column
F11 GOLD - TypeError: value is of the wrong type for this column
Status: CLOSED DUPLICATE of bug 503821
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-06-10 17:37 EDT by Jeff Burke
Modified: 2009-06-12 07:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-12 07:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2009-06-10 17:37:22 EDT
Description of problem:
 Using the interface system-config-users no longer starts. I unchecked the option for Hide system users and groups. Now the application no longer starts.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open a terminal window, su - , run system-config-users
2. Click on Edit, Preferences, Uncheck "Hide system users and groups"
3. Note on the terminal widow you will get a traceback
Actual results:
# system-config-users 
Traceback (most recent call last):
  File "/usr/share/system-config-users/system-config-users.py", line 46, in <module>
  File "/usr/share/system-config-users/mainWindow.py", line 311, in __init__
  File "/usr/share/system-config-users/mainWindow.py", line 517, in refresh
  File "/usr/share/system-config-users/mainWindow.py", line 616, in populate_lists
  File "/usr/share/system-config-users/mainWindow.py", line 574, in populate_user_list
    self.userStore.set_value(iter, 1, uidNumber)
TypeError: value is of the wrong type for this column

Expected results:
Application should launch normally

Additional info:
Comment 1 Nils Philippsen 2009-06-12 07:32:26 EDT

*** This bug has been marked as a duplicate of bug 503821 ***

Note You need to log in before you can comment on or make changes to this bug.