Bug 505186 - Allow Installation of Cobbler on s390x
Allow Installation of Cobbler on s390x
Status: CLOSED DUPLICATE of bug 580072
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-06-10 18:12 EDT by Devan Goodwin
Modified: 2010-08-26 04:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 04:55:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-06-10 18:12:59 EDT
Description of problem:

Cobbler as of 1.6.5 has a requirement on the syslinux package, but only for x86 and x86_64 architectures. On s390x, because of this missing requirement (which cannot be added as I understand the syslinux package does not exist on this arch) the Satellite installer prints the following warning:

* Update configuration in database.
* Setting up Cobbler..
Could not find files matching /usr/share/syslinux/pxelinux.0

* Restarting services.

We can't fix the bug originally reported in bug #505133, so we're filing this one to investigate either having it be silently ignored, or having it become an actual error that halts installation. (mdehaan recommends this as pxe provisioning will be broken until syslinux is manually installed)


Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090605.1, cobbler 1.6.5.

How reproducible:

Seems to be 100% on s390x.

Steps to Reproduce:
1. Begin install.pl on s390x RHEL 5 system.
  
Actual results:

Warning as displayed above.


Expected results:

TBD. :) Could be warning is suppressed, displayed differently, or treated as an error and installation halts.

Additional info:

mdehaan can probably clarify more on why the syslinux requires is removed for s390x, and also as noted above his opinion is that this should become a fatal error for the installer.
Comment 1 Brad Hinson 2010-08-26 04:55:52 EDT

*** This bug has been marked as a duplicate of bug 580072 ***

Note You need to log in before you can comment on or make changes to this bug.