Bug 505187 - Patch: map CapsLock to Super or Hyper
Patch: map CapsLock to Super or Hyper
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 18:17 EDT by Jason Woofenden
Modified: 2009-08-17 19:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 19:23:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to enable CapsLock to be mapped to Super or Hyper (3.30 KB, patch)
2009-06-10 18:17 EDT, Jason Woofenden
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 23356 None None None Never

  None (edit)
Description Jason Woofenden 2009-06-10 18:17:08 EDT
Created attachment 347301 [details]
patch to enable CapsLock to be mapped to Super or Hyper

Description of problem:

I have a patch, which makes it so you can choose to have your CapseLock key be either Super or Hyper with a radio button in the gnome-keyboard-properties gui.

It's very handy for people like me with laptop keyboards that are short on modifier keys on the bottom row (just ctrl and alt).

The only way I know how to achieve this, is by editing a bunch of system files. Which are overwritten every few weeks when I do "yum update".

I'm asking that it be included, so others can easily use this feature, and so I don't have to keep editing system files every update.

I created this patch by following the tutorial here:

http://forums.fedoraforum.org/showthread.php?t=209530

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Hutterer 2009-08-16 20:54:31 EDT
Patch upstreamed, waiting for maintainer. Please subscribe yourself to the upstream bug so you too get to see the comments from the upstream maintainer.

https://bugs.freedesktop.org/show_bug.cgi?id=23356
Comment 2 Peter Hutterer 2009-08-17 19:23:22 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1610962

turns out caps:super was already in upstream anyway, caps:hyper is added now.

Note You need to log in before you can comment on or make changes to this bug.