Bug 505195 - (Agent) Java applet doesn't work with Sampo Pankki's netbank
Java applet doesn't work with Sampo Pankki's netbank
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 18:46 EDT by mursusoft
Modified: 2016-06-17 03:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-13 09:09:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mursusoft 2009-06-10 18:46:36 EDT
Description of problem:

Java applet doesn't work with this netbank, it's starts loading but then it just seems to loop and nothing happens after that ---> can't access ---> can't use it.

Version-Release number of selected component (if applicable):

OpenJDK 1.6.0.0-18.b16.fc10 (x86_64)

How reproducible:
Very! 
Goto: https://verkkopankki.sampopankki.fi/html/index.html?site=SBNBFI&secsystem=E2

Steps to Reproduce:
1.Open Konqueror or Firefox
2.Goto: https://verkkopankki.sampopankki.fi/html/index.html?site=SBNBFI&secsystem=E2
3.Wait, applet tries to load but nothing happens.
  
Actual results:

Applet doesn't load like it should.

Expected results:

Bank loads security java applet and the log in prompt appears.
Comment 1 Markku Sukanen 2009-06-24 04:56:34 EDT
This is a BAD bug.  Because the applet locks up, cannot use any site which relies on ID verification from Sampo Pankki (in case you don't have a bank account in any other bank w/ online ID verification system...).
Comment 2 Deepak Bhole 2009-06-24 10:42:23 EDT
Can you please try it with this build and see if it makes a difference?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1418950

If it still crashes, I will need to see the debug logs. To get them, please close all instances of firefox, open up a terminal and run:

ICEDTEAPLUGIN_DEBUG=true firefox 2>&1 | tee console.log

and try to log in. Once you have done it, check the console.log and ~/.icedteaplugin/java.std* files for any personal info and remove it if there, and then please attach those files to this issue.
Comment 3 mursusoft 2009-09-26 13:44:38 EDT
Still doesn't work. BTW you don't need to login to see that issue or give any personal information. It should just load the login prompt which naturally anyone can see and now it doesn't load it.
Comment 4 mursusoft 2009-11-13 09:00:34 EST
Great! Just noticed that it works now. :)))))))
Comment 5 mursusoft 2009-11-13 09:06:37 EST
Not with latest Konqueror (could be of course unrelated to openjdk), but with Firefox 3.5.5 it works fine now.

Note You need to log in before you can comment on or make changes to this bug.