Bug 505215 - gnome-terminal display is slow
gnome-terminal display is slow
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 23:53 EDT by Manuel Fasse
Modified: 2010-06-28 08:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manuel Fasse 2009-06-10 23:53:05 EDT
Description of problem:
It seems that gnome-terminal has a problem with a lot of changing text on the screen. especially when scrolling man pages or huge text files this comes apparent. the overall speed of the scrolling slows down quite a bit which is very annoying.
In rxvt this doesn't happen.
In tty2 this doesn't happen.
In earlier releases this didn't happen.

I asked about this in #fedora and someone suggested it might be graphics acceleration related.
I have a i915 graphics adapter with the xorg-drv-intel-2.7.0 driver.
glxinfo shows "direct rendering: Yes" if that's important.
Also, I already tried disabling kernelmodesetting and changing the accelmethod in xorg.conf to EXA and XAA. The latter even made it worse.
On a side note: changing the focus between multiple large/fullscreen windows via alt-tab or the taskbar also seems a bit lagged. Maybe this is related.

Version-Release number of selected component (if applicable):
2.26-1.1.fc11

Steps to reproduce:
1. open gnome-terminal
2. open a longer man page like sudo
3. scroll down
  
Actual results:
Every line scrolled appears only after some waiting time which makes scrolling far distances very slow.

Expected results:
Every scrolled line appears immediately after pressing the button.
Comment 1 Manuel Fasse 2009-06-16 22:56:25 EDT
is there really no explanation? i'd really like to use fedora11 but i cant work like this :(
Comment 2 Manuel Fasse 2009-07-21 07:11:30 EDT
Upgrading to xorg-x11-drv-intel-2.8.0-0.3.fc12 seems to have fixed it, or at least diminished it into only being barely noticable
Comment 3 Bug Zapper 2010-04-27 10:45:38 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-06-28 08:53:16 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.