Bug 505252 - [kn_IN][Rendering Issue] Dotted Cricle appearing between 0C8E and 0C82 in openoffice applications
[kn_IN][Rendering Issue] Dotted Cricle appearing between 0C8E and 0C82 in ope...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 03:51 EDT by Shankar Prasad
Modified: 2015-04-21 00:34 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.0.1-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Examples of 0C8E+0C82 combinations, as seen in oowriter (92.33 KB, image/png)
2009-06-11 03:51 EDT, Shankar Prasad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 481205 None None None Never

  None (edit)
Description Shankar Prasad 2009-06-11 03:51:46 EDT
Created attachment 347351 [details]
Examples of 0C8E+0C82 combinations, as seen in oowriter

Description of problem:
Dotted cricle appearing between 0C8E and 0C82 combinations.

Version-Release number of selected component (if applicable):
openoffice.org:3.1.0-11.3.fc11


How reproducible:
Everytime

Steps to Reproduce:
1.Open any openoffice application
2.Activate ibus, choose Kannada inscript input method
3.inscript key mapping	        
ಎಂಬ 	   -	Zxy		
ಎಂತಹ	  -	Zxlu		
ಎಂದು	  -	Zxog        
ಎಂಟು	  -	Zx'g	
  
Actual results:
Dotted circle is appearing

Expected results:
The Dotted Circle should not be formed between the Combination of 0C8E and 0C82

Additional info:
Similar issue was reported for pango in gnome bugzilla at http://bugzilla.gnome.org/show_bug.cgi?id=481205
Comment 1 David Tardon 2009-06-11 04:31:28 EDT

*** This bug has been marked as a duplicate of bug 221870 ***
Comment 2 Caolan McNamara 2009-06-11 06:00:33 EDT
hmm, hang on, OOo goes through icu, the pango tables are typically based on the icu ones, but the icu ones are unchanged. Need to have a look at this from an icu perspective.
Comment 4 Caolan McNamara 2009-06-11 06:59:43 EDT
the pango change looks sane, filed upstream as http://bugs.icu-project.org/trac/ticket/6995 and checked into devel and F-11

0C8C;KANNADA LETTER VOCALIC L;Lo;0;L;;;;;N;;;;;
0C8E;KANNADA LETTER E;Lo;0;L;;;;;N;;;;;

there is no 0x0C8D, so presumably it should be marked as _xx in the table rathern than 0x0C8E as present
Comment 5 Fedora Update System 2009-06-11 07:00:18 EDT
icu-4.0.1-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/icu-4.0.1-4.fc11
Comment 6 Fedora Update System 2009-06-15 21:36:25 EDT
icu-4.0.1-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update icu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6087
Comment 7 Fedora Update System 2009-06-24 15:35:48 EDT
icu-4.0.1-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Steven R. Loomis 2010-10-07 20:22:44 EDT
FYI committed upstream(In reply to comment #4)
> the pango change looks sane, filed upstream as
> http://bugs.icu-project.org/trac/ticket/6995 and checked into devel and F-11
> 
> 0C8C;KANNADA LETTER VOCALIC L;Lo;0;L;;;;;N;;;;;
> 0C8E;KANNADA LETTER E;Lo;0;L;;;;;N;;;;;
> 
> there is no 0x0C8D, so presumably it should be marked as _xx in the table
> rathern than 0x0C8E as present


FYI committed upstream, targetted for ICU 4.6

Note You need to log in before you can comment on or make changes to this bug.