Bug 505292 - kde-plasma-networkmanagement-0.1-0.12.20090519svn.fc11.x86_64 does not work with wpa
kde-plasma-networkmanagement-0.1-0.12.20090519svn.fc11.x86_64 does not work w...
Status: CLOSED DUPLICATE of bug 494262
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Ben Boeckel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 07:45 EDT by Neal Becker
Modified: 2009-06-17 20:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 20:57:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 195824 None None None Never

  None (edit)
Description Neal Becker 2009-06-11 07:45:37 EDT
Description of problem:
Was working on F10, but after update to F11 will not connect to WPA/WPA2.
nm-applet works fine.

One thing different in log:
Broken sequence:
Jun 10 20:00:44 nbecker1 NetworkManager: <info>  Config: added 'ssid' value 'nbecker'
Jun 10 20:00:44 nbecker1 NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Jun 10 20:00:44 nbecker1 NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-PSK'
Jun 10 20:00:44 nbecker1 NetworkManager: <info>  Config: added 'auth_alg' value 'OPEN'
Jun 10 20:00:44 nbecker1 NetworkManager: <info>  Config: added 'psk' value '<omitted>'

Good sequence:
Jun 10 20:01:35 nbecker1 NetworkManager: <info>  Config: added 'ssid' value 'nbecker'
Jun 10 20:01:35 nbecker1 NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Jun 10 20:01:35 nbecker1 NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-PSK'
Jun 10 20:01:35 nbecker1 NetworkManager: <info>  Config: added 'psk' value '<omitted>'

I'm told 'auth_alg' 'OPEN' is not valid for WPA/WPA2

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2009-06-11 15:18:35 EDT
Can you please try downgrading NetworkManager to this version?
http://koji.fedoraproject.org/koji/taskinfo?taskID=1405910
This is the F10 SRPM of NetworkManager rebuilt for F11.
Comment 2 Rex Dieter 2009-06-11 15:31:23 EDT
Dan, any ideas or input to help diagnose what's going wrong here?
Comment 3 Kevin Kofler 2009-06-12 03:14:19 EDT
Ping? Neal (or anybody else on F11 who can reproduce this problem), can you please try downgrading NM to the above scratch build to see if it helps?

If it doesn't help, there are other downgrades we could try, like wpa_supplicant.

(Of course downgrading isn't a real fix, but it'd make it work for you for now and it could at least help us find the real issue.)
Comment 4 Neal Becker 2009-06-12 07:29:43 EDT
I'll try tonight (still recovering from ext4 disaster)
Comment 5 Stefan Neufeind 2009-06-13 05:41:09 EDT
Tried downgrading. However that didn't help unfortunately.

In my special case unfortunately the WPA2-protected network also has a hidden SSID, so kde-plasma-networkmanagement 090519 at first doesn't find the network. But when explicitly running an "iwlist wlan0 scan essid mynetwork" it sees the network and also tries to connect:

NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...                                               
NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...                                                 
NetworkManager: <info>  (wlan0): device state change: 6 -> 4                                                                        
NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...                                             
NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.                                                  
NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...                                              
NetworkManager: <info>  (wlan0): device state change: 4 -> 5                                                                        
NetworkManager: <info>  Activation (wlan0/wireless): connection 'mynetwork' has security, and secrets exist.  No new secrets needed.
NetworkManager: <info>  Config: added 'ssid' value 'mynetwork'                                                                      
NetworkManager: <info>  Config: added 'scan_ssid' value '1'                                                                         
NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-PSK'                                                                    
NetworkManager: <info>  Config: added 'auth_alg' value 'OPEN'                                                                       
NetworkManager: <info>  Config: added 'psk' value '<omitted>'                                                                       
NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.                                                
NetworkManager: <info>  Config: set interface ap_scan to 1                                                                          
NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning                                             
NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associating                                              
NetworkManager: <info>  (wlan0): supplicant connection state:  associating -> associated                                            
NetworkManager: <info>  (wlan0): supplicant connection state:  associated -> 4-way handshake                                        
NetworkManager: <info>  (wlan0): supplicant connection state:  4-way handshake -> disconnected                                      
NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning                                             
NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associated                                               
NetworkManager: <info>  (wlan0): supplicant connection state:  associated -> 4-way handshake                                        
NetworkManager: <info>  (wlan0): supplicant connection state:  4-way handshake -> disconnected                                      
NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning                                             
NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associated                                               
NetworkManager: <info>  (wlan0): supplicant connection state:  associated -> 4-way handshake                                        
NetworkManager: <info>  (wlan0): supplicant connection state:  4-way handshake -> disconnected                                      
NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning                                             
NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associated                                               
NetworkManager: <info>  (wlan0): supplicant connection state:  associated -> 4-way handshake                                        
NetworkManager: <info>  (wlan0): supplicant connection state:  4-way handshake -> disconnected
Comment 6 Neal Becker 2009-06-13 07:47:46 EDT
Downgraded, restarted NM.  Stopped nm-applet.  Started (current F11) kde-plasma-networkmanagement.

Didn't work.  Same symptoms as before.

Killed kde-plasma-networkmanagement.  Start nm-applet.  Worked fine (other than asking for password).
Comment 7 Kevin Kofler 2009-06-13 14:25:42 EDT
OK, rdieter also said on IRC that downgrading NM didn't help. So it's not the NM version. Then what is it? wpa_supplicant maybe? I have a scratch build for a wpa_supplicant downgrade here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1408327
Comment 8 Gerald Cox 2009-06-16 13:54:44 EDT
Believe this is a duplicate of 494262.
Comment 9 Gerald Cox 2009-06-17 20:57:58 EDT

*** This bug has been marked as a duplicate of bug 494262 ***

Note You need to log in before you can comment on or make changes to this bug.