Bug 505317 - virtinst: make SLES11 guests use virtio by default
virtinst: make SLES11 guests use virtio by default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-11 09:33 EDT by Erik Jacobson
Modified: 2009-10-07 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 08:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Jacobson 2009-06-11 09:33:19 EDT
Currently, the virt-manager 'Create a new virtual machine' dialog offers the
Version choice of 'Suse Linux Enterprise Server'.

When this is used to create a SLES11 machine, virtio devices are not used by
default for said SLES11 guest.

However, SLES11 supports virtio devices just fine.

So far, when I've installed SLES11 guests with this dialog, I've answered
"Fedora 11" for Version so that virtio is enabled for the SLES11 guest I create. 
This is a bit non-intuitive.

In my very basic performance tests, SLES11 and Fedora11 guests perform similarly
in terms of virtio for a Fedora11 guest.  My basic test is an IO intensive test 
and entails simply a timed kernel+module build of the linux tree.

Test host machine is Fedora11 (upgraded to current from preview).
Relevant pkg versions:

qemu-kvm-0.10.4-4.fc11.x86_64
virt-manager-0.7.0-5.fc11.x86_64
libvirt-0.6.2-11.fc11.x86_64
Comment 1 Daniel Berrange 2009-06-11 09:40:56 EDT
Moving to python-virtinst component, since that's where the OS configuration data tables are stored.
Comment 2 Erik Jacobson 2009-06-11 10:13:23 EDT
python-virtinst is at this level on the test machine:

python-virtinst-0.400.3-8.fc11.noarch

Thanks; sorry I got the component wrong.
Comment 3 Cole Robinson 2009-07-14 21:58:35 EDT
Fixed upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/dbda3bfc28f8

Moving to POST
Comment 4 Mark McLoughlin 2009-08-07 09:25:24 EDT
Resolved for F-12 by python-virtinst-0.500.0-1.fc12; perhaps worth backporting to F-11
Comment 5 Fedora Update System 2009-09-13 20:03:42 EDT
python-virtinst-0.400.3-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.3-9.fc11
Comment 6 Fedora Update System 2009-09-15 03:37:10 EDT
python-virtinst-0.400.3-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9548
Comment 7 Fedora Update System 2009-10-06 23:10:27 EDT
python-virtinst-0.400.3-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9548
Comment 8 Cole Robinson 2009-10-07 08:29:32 EDT
This should be fixed by python-virtinst-0.400.3-10.fc11 now in stable. Closing.

Note You need to log in before you can comment on or make changes to this bug.