Bug 50532 - Roswell failed to detect logical drive on PERC3/SC (AMI MegaRAID 475)
Summary: Roswell failed to detect logical drive on PERC3/SC (AMI MegaRAID 475)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i586
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-31 22:49 UTC by Danny Trinh
Modified: 2005-10-31 22:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 19:53:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog file (7.82 KB, text/plain)
2001-07-31 22:51 UTC, Danny Trinh
no flags Details
dmesg of sys after installing Fairfax Beta3, added the card, and insmod megaraid (13.33 KB, text/plain)
2001-08-01 22:10 UTC, Tesfamariam Michael
no flags Details

Description Danny Trinh 2001-07-31 22:49:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When I run installation program by using CD1, it failed to detect logical 
drive (RAID1) on PERC3/SC (AMI MegaRaid 475). This happens when I tried to 
partition the harddrive, and the error saying "..no valid device..."

How reproducible:
Always

Steps to Reproduce:
1.Connect 2 HDD to AMI MegaRAID 475, create RAID1
2.Insert CD1 to CD-ROM drive and reboot system
3.Follow the instruction on screen
	

Actual Results:  Unable to complete installation

Expected Results:  Should be able to see the logical volume during 
installation.

Additional info:

Comment 1 Danny Trinh 2001-07-31 22:51:44 UTC
Created attachment 25679 [details]
Syslog file

Comment 2 Matt Domsch 2001-08-01 00:20:12 UTC
What server and BIOS level?  Looks like IRQs aren't getting routed properly, 
and the first obvious symptom is a lack of disk I/O.

usb.c: registered new driver hub
PCI: Found IRQ 5 for device 00:0f.2
IRQ routing conflict for 00:0f.2, have irq 10, want irq 5
eepro100.c: $Revision: 1.36 $ 2000/11/17
PCI: Found IRQ 9 for device 00:02.0
IRQ routing conflict for 00:02.0, have irq 11, want irq 9
megaraid: v1.17a (Release Date: Fri Jul 13 18:44:01 EDT 2001)
PCI: Found IRQ 10 for device 01:04.0
IRQ routing conflict for 01:04.0, have irq 5, want irq 10


Comment 3 Danny Trinh 2001-08-01 13:11:22 UTC
I tested on two servers (PE1300, PE1400), the results are the same. Both 
servers have the lastest BIOS. However, the installation process works very 
well with PERC3/DC, PERC2/DC.

Comment 4 Tesfamariam Michael 2001-08-01 20:06:23 UTC
I was able to install Fairfax Beta 2 on this controller (same firmware and 
config) successfully.

Comment 5 Glen Foster 2001-08-01 20:23:27 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 6 Matt Wilson 2001-08-01 21:05:52 UTC
nothing with regard to this controller changed in anaconda; moving to kernel.


Comment 7 Arjan van de Ven 2001-08-01 21:12:07 UTC
I could install it on my Dell PERC3 just fine too, I'll check asap which exact
model it is (it has 128Mb ram)

Comment 8 Tesfamariam Michael 2001-08-01 22:10:19 UTC
Created attachment 25912 [details]
dmesg of sys after installing Fairfax Beta3, added the card, and insmod megaraid

Comment 9 Tesfamariam Michael 2001-08-01 22:16:08 UTC
After installing the megaraid driver, it detects the logical volume but it was 
not given a device name (/dev/sdb). Below is the log message when the megaraid 
driver is installed. 
     megaraid: v1.17a (Release Date: Fri Jul 13 18:44:01 EDT 2001)
     megaraid: found 0x101e:0x1960:idx 0:bus 1:slot 6:func 0
     scsi3 : Found a MegaRAID controller at 0xf89e2000, IRQ: 20
     scsi3 : Enabling 64 bit support
     megaraid: [1.62:3.17] detected 1 logical drives
     megaraid: channel[1] is raid.


Comment 10 Bob Matthews 2001-08-08 22:28:37 UTC
I tried this card (perc3/sc) in a 6450 with todays tree.  Anaconda sees the
card, but hangs loading the driver.

Comment 11 Tesfamariam Michael 2001-08-09 19:53:20 UTC
There is an issue with installing onto PE6450 (bugzilla # 50775). Try the work 
around suggested there.


Comment 12 Matt Domsch 2001-08-20 20:34:29 UTC
AMI reproduced the problem, and fixed it.  Go into controller setup during POST,
and press Alt-F to reset to factory defaults.  This somehow clears bad state in
NVRAM.  Dell has sent another failing card to AMI to troubleshoot exactly why it
fails for future fixes.  I'm marking this as closed (from RH's perspective, it's
NOTABUG.)


Note You need to log in before you can comment on or make changes to this bug.