Bug 505324 - Session logged out when trying to change GNOME desktop background.
Session logged out when trying to change GNOME desktop background.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 10:03 EDT by Chris Moller
Modified: 2009-07-19 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 11:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of possible Xorg failure. (163.17 KB, text/plain)
2009-06-11 10:42 EDT, Chris Moller
no flags Details

  None (edit)
Description Chris Moller 2009-06-11 10:03:04 EDT
Description of problem:

Very weird--under GNOME, I right-click on the desktop and then click to change the desktop background.  The background selection window, with thumbnails of the available backgrounds pops up, and then, with no further input from me--no clicks, no mouse movement, etc.--I get logged out and the normal login screen appears. 

I put this under gnome-common, but I really don't have a clue where the problem is.  Might even be xorg.


Version-Release number of selected component (if applicable):

Out-of-the-box F11, straight from the NCSU Fedora mirror.


How reproducible:

Today, it fails every time; yesterday, it worked and I had no problem selecting a new background.

Steps to Reproduce:
1.  Right-click on the desktop
2.  Click "Change Desktop Background"
3.
  
Actual results:

Thumbnail selection window comes up, then I'm immediately logged out and am back at the login screen.

Expected results:

I select a background and go back to hacking.


Additional info:

The only thing that occurs to me is that I'm running an ATI card, a Radeon, I think, with two heads in non-mirrored mode.  Maybe that has something to do with it, but everything else works fine.
Comment 1 Toshio Ernie Kuratomi 2009-06-11 10:24:21 EDT
gnome-common is a small package that helps programmers create build scripts for gnome apps so it's definitely not at the root of this issue.

Can you attach your /var/log/Xorg.0.log and, if you're using one, your /etc/X11/xorg.conf?  Reassigning to xorgg for further diagnosis.
Comment 2 Chris Moller 2009-06-11 10:42:28 EDT
Created attachment 347413 [details]
Log of possible Xorg failure.

Both of my screens are set to 1280x1024 even though they have different display types--one is an old CRT, the other is an LCD.
Comment 3 Chris Moller 2009-06-11 10:44:56 EDT
I don't have an /etc/X11/xorg.conf.  I set up the dual-head from GNOME with System>>Preferences>>Display--I have no idea where it's keeping the configuration information.
Comment 4 Hans Ulrich Niedermann 2009-07-19 09:43:03 EDT
The Xorg.0.log says you're using the radeon driver from the -ati package.

Reassigning the bug accordingly.
Comment 5 Chris Moller 2009-07-19 11:38:21 EDT
Even I can't reproduce the bug any more.

Note You need to log in before you can comment on or make changes to this bug.