Bug 505332 - KVM doesn't shut down with WinXP
KVM doesn't shut down with WinXP
Status: CLOSED DUPLICATE of bug 495964
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 10:29 EDT by Brian Wheeler
Modified: 2009-06-11 11:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 11:18:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Wheeler 2009-06-11 10:29:17 EDT
Description of problem:

when running qemu-kvm and shutting down the guest, kvm never finishes.

Version-Release number of selected component (if applicable):

qemu-kvm-0.10.5-1.fc11.x86_64
qemu-kvm-tools-0.10.5-1.fc11.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Run

export QEMU_AUDIO_DRV=sdl
/usr/bin/qemu-kvm -hda /home/bdwheele/QEmu/WinXP/disk0.img \
    -m 512 \
    -soundhw sb16,pcspk \
    -localtime \
    -net nic,model=rtl8139,macaddr=DE:AD:BE:EF:00:01  -net user \
    $*


2. after windows comes up, select shutdown
  
Actual results:

windows shuts down but kvm doesn't exit. Window close doesn't work, either. You have to hit ctrl-z and then kill the kvm process.

Expected results:

prompt comes back

Additional info:
Comment 1 Mark McLoughlin 2009-06-11 11:18:04 EDT
Thanks for the report, but it's a known issue

You can use QEMU_AUDIO_DRV=pa as a workaround

*** This bug has been marked as a duplicate of bug 495964 ***

Note You need to log in before you can comment on or make changes to this bug.